SABNZBD 2.0.0 released, new features

  • SABNZBD 2.0.0 has been released and they have new features/plugins that can be installed/enabled. Not sure if anyone has looked up on this yet or not. They now have SABYenc and a multicore par2 add on. The SABYenc helps speed up downloading a little on low power devices (although I haven't had any issues with download speed), and the multicore par2 helps speed up extraction of pars and repair by utilizing multiple cores of the processor. They have instructions on how to install on ubuntu as well as other distros. Anyone make any attempt at doing this yet?


    Also just wondering if this is something that I should just wait for to see if it'll be wrapped into the plugin or if it will never be wrapped into the plugin and I should just go ahead and do the install.

  • Hi


    To install par2-tbb I have done


    apt-get install software-properties-common python-software-properties
    add-apt-repository ppa:jcfp/sab-addons
    nano /etc/apt/sources.list.d/jcfp-sab-addons-jessie.list


    Change references to wheezy or jessie to trusty


    apt-get update
    dpkg -P --force-all par2
    apt-get install par2-tbb


    I have no more message of par2 multicore unavailable in SAB settings (after reboot of SAB !!!)


    And for sabyenc you just have to follow the steps on this page


    https://sabnzbd.org/wiki/installation/sabyenc.html


    Personnaly I have use


    apt-get install python-sabyenc


    (because repo for par2-tbb is the same)

    English isn't my native language, so, sorry if I made any mistake ^-^


    OMV 4.1.6 | 64 bit | openmediavault-omvextrasorg 4.1.6

    Edited 7 times, last by jroch74: Added required dependencies ().

  • Hi


    Just updated to 2.0.1 and im getting the warning SABYenc module... NOT found! Expecting v3.0.2 - https://sabnzbd.org/sabyenc


    Tried to follow you commands but im getting
    root@openmediavault:/# add-apt-repository ppa:jcfp/sab-addons
    -bash: add-apt-repository: command not found


    any suggestions?

    OMV 5 - 64 bit
    Dell T430, 16gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • Hi I have the same issue as chclark



    Just updated to 2.0.1 and im getting the warning SABYenc module... NOT found! Expecting v3.0.2 - sabnzbd.org/sabyenc



    Tried to follow you commands but im getting also
    root@openmediavault:/# add-apt-repository ppa:jcfp/sab-addons
    -bash: add-apt-repository: command not found


    any ideas

  • Hello :)


    apt-get install software-properties-common python-software-properties


    I will edit my post ;)

    English isn't my native language, so, sorry if I made any mistake ^-^


    OMV 4.1.6 | 64 bit | openmediavault-omvextrasorg 4.1.6

  • Hello :)


    apt-get install software-properties-common python-software-properties


    I will edit my post ;)

    thanks i have done this but it seems to of made things worse lol i now get at this point


    root@openmediavault:~# apt-get -f install par2-tbb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    par2-tbb : Depends: libtbb2 but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


    and


    root@openmediavault:~# apt-get install python-sabyenc
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    openmediavault-sabnzbd : Depends: par2-tbb but it is not going to be installed or
    par2
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


    so now sabz says



    ERROR:par2 binary... NOT found!


    WARNING:SABYenc module... NOT found! Expecting v3.0.2 - https://sabnzbd.org/sabyenc

    OMV 5 - 64 bit
    Dell T430, 16gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • You have try to do apt-get -f install ?

    Yes same error luckyly i hadent done the latest update yet so that fixed the par 2 issue.


    so i just tried running the apt-get install python-sabyenc cmd again and its work this time and no warning in sabz


    Thanks

    OMV 5 - 64 bit
    Dell T430, 16gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • Got the same error es chclark and can't get it to work. What exactly did you do?

    is sabz showing an update avalible still is so go to the omv gui go to the sabz plugin tab and click the update button that will fix the par issue well it did for me.


    Then all I had to do to clear the last error was run the instructions above but missing out the commands that are for installing par2.


    So all I did was run


    apt-get install python-sabyenc


    Since the other part for the repository of allready done.

    OMV 5 - 64 bit
    Dell T430, 16gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • I don’t know why libtbb2 doesn’t want to install :-/


    What’s the output of


    apt-cache policy libtbb2

    English isn't my native language, so, sorry if I made any mistake ^-^


    OMV 4.1.6 | 64 bit | openmediavault-omvextrasorg 4.1.6


  • The omv webinterface doesn't show any update for me (current sab version is 2.1.0).



    That's where I'm stuck:


    Code
    apt-get install par2-tbb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    par2-tbb : Depends: libtbb2 but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    Code
    apt-get install python-sabyenc
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    openmediavault-sabnzbd : Depends: par2-tbb but it is not going to be installed or
    par2
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


    An -f install doesn't help.


    edit: I did get updates through the omv update manager gui for par2-ttb and after installing them everything worked as intended.

  • Im getting similar warning messages after installing the plugin on clean OMV3 build, any ideas?


    1) Your UNRAR version is 0.00, we recommend version 5.00 or higher.
    2) SABYenc module... NOT found! Expecting v3.0.2 - https://sabnzbd.org/sabyenc



    Code
    apt-get install par2-tbb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package par2-tbb is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package 'par2-tbb' has no installation candidate


    Code
    apt-get install python-sabyenc
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package python-sabyenc
  • Great thanks, first steps worked for me.
    Could use a bit more help on the UnRAR install please. Assume its this version I download RAR 5.40 for Linux x64' - Do I just copy the folder structure in the downloaded RAR to the root of the OMV server?


    (Managed to install apt-get install p7zip-full but still get the warning - Your UNRAR version is 0.00, we recommend version 5.00 or higher.)

  • Found this which seems to work, however now warns me "Your UNRAR version is 4.10, we recommend version 5.00 or higher"Any ideas?

    Code
    sudo echo 'deb ftp://ftp.us.debian.org/debian/ wheezy non-free
    deb http://security.debian.org/ wheezy/updates non-free deb http://volatile.debian.org/debian-volatile wheezy/volatile non-free' >> /etc/apt/sources.list.d/wheezy.non-free.list
    sudo apt-get update
    sudo apt-get install unrar
  • Thanks for the steps. The first ones went fine, but at apt-get-update it gives 404 errors, failed to fetch. What am I doing wrong ?


    It would be awesome to get it to work! Thanks.


    Bash
    W: Ophalen van http://ppa.launchpad.net/jcfp/sab-addons/ubuntu/dists/jessie/main/source/Sources is mislukt 404 Not Found
    W: Ophalen van http://ppa.launchpad.net/jcfp/sab-addons/ubuntu/dists/jessie/main/binary-amd64/Packages is mislukt 404 Not Found
    E: Ophalen van sommige indexbestanden is mislukt. Deze zijn of genegeerd, of er zijn oudere versies van gebruikt.
  • Thanks for the steps. The first ones went fine, but at apt-get-update it gives 404 errors, failed to fetch. What am I doing wrong ?


    It would be awesome to get it to work! Thanks.



    Bash
    W: Ophalen van http://ppa.launchpad.net/jcfp/sab-addons/ubuntu/dists/jessie/main/source/Sources is mislukt 404 Not Found
    W: Ophalen van http://ppa.launchpad.net/jcfp/sab-addons/ubuntu/dists/jessie/main/binary-amd64/Packages is mislukt 404 Not Found
    E: Ophalen van sommige indexbestanden is mislukt. Deze zijn of genegeerd, of er zijn oudere versies van gebruikt.

    Already fixed it! It was my own stupidity. I'm not the best Linux kid. But with the help of the internet I'll be fine :)

  • How did you solved this?
    @jroch74 @wietje91


    im using OMV 3.x


    when i do this:


    sudo add-apt-repository ppa:jcfp/sab-addons
    sudo apt-get update
    sudo apt-get install python-sabyenc



    when i do apt-get update i get this error:


    Code
    W: Fehlschlag beim Holen von http://ppa.launchpad.net/jcfp/sab-addons/ubuntu/dists/jessie/main/binary-amd64/Packages 404 Not Found
    E: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.


    my /etc/apt/sources.list.d/jcfp-sab-addons-jessie.list looks like this:



    Code
    deb http://ppa.launchpad.net/jcfp/sab-addons/ubuntu jessie main

    when i # this entry, apt-update works without an error but dont solve my problem in sabnzb :(




    Thanks for help!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!