Mdadm device (/dev/md3) raid5 get lost on every reboot

  • Hi to every one.


    Im having an issue, similar to this guy : [RAID5] Missing superblocks after restart


    Didnt want to post on these thread since is quite old.


    Im creating an mdadm with (it defaults to 1.2) :


    Code
    mdadm --create --verbose /dev/md3 --level=5 --raid-devices=4 /dev/sda /dev/sdb /dev/sde /dev/sdf





    Then after several hours it finnish and i create the fs with mkfs, update the mdadm.conf and im able to mount the raid.


    Code
    mfks.ext4 /dev/md3 ; mdadm --details --scan >> /etc/mdadm/mdadm.conf ; update-initramfs -u


    Evferything is ok, then I reboot and system cannot mount the fstab entry because md3 is not being initialized, why ? the superblocks are gone (tried several times and occasionally one of the disk still remains intact ) :



    The difference with the other guy is that I have another 2 raid 1 running fine in the board (verything create from scratch ) on 2 drives :


    As you can note, it is one raid 5 partition, thats because im testing, now im creating the array with partitions with type raid set instead of the full disk, wish me good luck.


    If any one has any hint please help, im very stucked here.

  • So far , now I rebooted the system and it went ok :



    It has everything :

    I dont get WHY, it fails when I tried before, the only change was, full disk in comparisson to using partitions, and the size of course.


    Now im trying again with partitions, typed to raid and full disk :

  • So far , now I rebooted the system and it went ok :



    It has everything :


    I dont get WHY, it fails when I tried before, the only change was, full disk in comparisson to using partitions, and the size of course.


    Well ! SOme hours later (lots of hours)


    Its working ok, it keeps nice and up after every reboot :





    So, final conclusion is, when using mdadm to raid5 , yo have to use partitions, and also set type to raid, not sure why.


    By the way, hardware :
    Assrock Q1900 DC + PCIE expansion sata card, 2 x 4 sata Tb green , 2 x 4 sata Tb red nas , 2 x 200 sata gb disk

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!