phpVirtualbox console not working - blank

  • phpVirtualBox 5.0-5


    I start the VM, can connect with VNC on port 9000, RDP also works fine, the preview in phpVirtualBox browser window shows the correct preview.
    But when i click on the Console button, the console is blank, only showing "Requested desktop size:" followd by a "Detach" Button.



    Code
    root@nas:~# service vboxweb-service status
    ● vboxweb-service.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)
    root@nas:~# service vboxweb-service start
    Failed to start vboxweb-service.service: Unit vboxweb-service.service failed to load: No such file or directory.

    That doesn't seem right... ?

  • Hey,
    Console will not allow you to connect because of java security policy.
    I found some thread on google to activate it but you need to add exceptions for all ports so I considered it as pain in the ass and use VNC/RDP.


    Also Chrome not support java more so no option here.
    Firefox will exclude java soon so also dead.
    Only IE will support java, so still bad choice :)


    Effort is not woth of this option.

    Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
    Processor: Intel Core 2 Duo E8400@3GHz
    Memory: 4GB RAM
    OS-HDD: Samsung SSD 120 GB +LVM


    Full media and download center configured.


    BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))


    ------------------------------


    Wise guy don't know everything, he can search or ask!
    Don't ask me via PM!

  • Hello
    Same issue here, I need to access the console and dont know how. I need to change my machine ip address and cannot connect.


    Whenn i press the connect button is does nothing, please help.


    Regards.


    Not: My verseion is Stone Burner 2.2.14

  • If it is on by default, then you should be able to use the remote desktop client to connect to the ip:port that it lists there. This is the same as connecting to the console.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • is the shell output as quoted in the OP expected behaviour ?

    No. Usually that happens when the vbox user has a different password than what is stored in /etc/default/openmediavault-virtualbox. We usually tell people to uninstall all virtualbox packages and plugin, delete vbox user, and the virtualbox files in /etc/default/. Then reinstall.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • is that a hash or plain text ?

    plain text. I suppose you could try setting the vbox user password to whatever is in that file. Then restart vboxweb-service.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • try setting the vbox user password to whatever is in that file. Then restart vboxweb-service.

    to no avail ...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!