Connecting with filezilla through sftp

  • I have been trying to connect to the server through sftp which I'm just testing, but I'm having no luck. Before I go on, I should mention that I am able to connect to the ftp share just fine when using ftp unsecure from the file zilla options. So I know that's working. I'm on omv 3.0.74. I have enabled all the options on and off and created the certificate, but no matter what I keep getting and error connecting. So I have turned all that off for now, but I was wondering if anyone had any ideas about why the sftp connection fails? I am using port 22 and have forwarded that port just to be sure. I just can't for the life of me figure out what may be happening since I have tried all the differnce combinations on those setting in the omv ftp page. I have also used the regular ftp setting in filezilla and changed the others below it along with the ssl on the ftp page of omv. If there is a guide I can check somewhere please let me know. Thanks.


    I should note that I'm using groups to add rights to whatever users I add so I don't have to do individual persons. I noticed that there is an sshd group under groups but ssh under user group.

  • SSL and the associated certificates in Filezilla have absolutely nothing to do with sftp.


    Are you using the correct host syntax for sftp with Filezilla?


    Host: sftp://omv-ip-address


    The user you are logging in as must exist as a user in OMV and must also be a member of the ssh group in OMV.


    Also, you should post the exact error you are seeing. Just saying that it does not work is inadequate.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

    Edited once, last by gderf ().

  • You're right it was a bit vague, but I did read that about adding the user to ssh. Since I'm using groups can I do add the group or it has to be the user? I know user will work but I'm also testing the rights with groups since I don't want to have to edit each user if I were to have a few. I won't here at home, but was just testing. I was just using the domain name in the host part and didn't type sftp on it but I'll try that since I totally forgot about that as well. I forgot what the error was that's why I didn't add it. Thanks.

  • In Filezilla an sftp connection must be to a host that has the sftp:// specifier. It will not work without it.


    Groups are populated with users, so I do not understand what problem you are having with them. But I will say this: You can not have a group made up of other groups.


    If you want to eliminate having to specify users into the ssh group in OMV, then you can disable that check:


    As root, edit the file /etc/default/openmediavault


    Comment out this line (add the # symbol to the front of the line):


    #OMV_SSHD_ALLOWGROUPS="root users ssh"


    Add this line:


    OMV_SSHD_ALLOWGROUPS=" "


    Then save the file.


    As root in the shell run the command: omv-mkconf ssh

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

    Edited 2 times, last by gderf ().

  • Okay I just tested adding the user homeftp to the ssh group and I am able to log into the server, but it takes me to the root of the system instead of the ftp share I have set up. On the second picture you can see the groups I have made so that I can leave all the rights alone when I first create a user and just make the changes under each group to keep it simple. The error I was also getting is the account error as you can see. So how do I make this go to the share and not the system root? I'm using homeftp as my test account. I added that to the ssh group and I was able to log in, but it took me to the wrong place. I guess I can leave that alone and do it for each user for now and just make all the privileged changes in each instead of the group as I have done here. The user itself does not have these privileges since I just left those user accounts at their defaults.


    Okay, i just changed the priviledges in the user as well and it still doesn't take me to the share.

  • You will need to configure what is called a chroot environment for sftp. See this Guide for the Framework:


    [GUIDE] SFTP Selective remote folder access to certain users



    Thanks. That looks painful, but at least I know what else is needed now if I really want to use it that way.


    There is an sftp plugin for this now. Very easy to use.

    omv 5.6.4 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • There is an sftp plugin for this now. Very easy to use.

    Thanks Aaron. I'm guessing that's your name from the name on your avatar, it it's not forgive me. The only reason I didn't do it it's because I was just testing this. I also read that part where it said I would have to unmount the share or drive or something to that effect and knowing me, I'll probably forget and lose a few files if I were to forget so that was the other reason I didn't want to leave that on. But good to know that. In any case the I shouldn't keep any files in an ftp drive/share anyway since that would be only for temporary transfers if I ever need it which I haven't for the longest time, but you never know.

  • There is an sftp plugin for this now. Very easy to use.

    Thanks Aaron. I'm guessing that's your name from the name on your avatar, it it's not forgive me. The only reason I didn't do it it's because I was just testing this. I also read that part where it said I would have to unmount the share or drive or something to that effect and knowing me, I'll probably forget and lose a few files if I were to forget so that was the other reason I didn't want to leave that on. But good to know that. In any case the I shouldn't keep any files in an ftp drive/share anyway since that would be only for temporary transfers if I ever need it which I haven't for the longest time, but you never know.


    Not sure if this means anything but I just started getting this error when I tried to submit this reply.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!