Is it possible to revert to an older version of a plugin, specifically openmediavault-shellinabox?

  • Is it possible to revert to an older version of a plugin?

    I am running OMV 2.x on a Banana Pi. All is working well. I believe I had shellinabox working previously. I recently did an apt-get update and apt-get upgrade and I believe it upgraded my openmediavault-shellinabox plugin. I'm not sure if that's what caused shellinabox to "fail" or it was something else.

    In any case, I currently have version 1.2 of openmediavault-shellinabox installed and I have version 2.14 of shellinabox installed. This version of shellinabox must have been installed through the OMV Gui when I installed the plugin. I did not install it myself.

    When I try to remove/install the plugin through the gui, the error message indicates that verion 2.18 or higher of shellinabox is required. The latest version of shellinabox available to my configuration is 2.14, the version that is already installed.

    In looking at the changelog for version 1.2 of openmediavault-shellinabox, it says:

    openmediavault-shellinabox (1.2) testing; urgency=low
    * Update depencies for shellinabox 2.18
    -- OpenMediaVault Plugin Developers <> Fri, 30 Oct 2015 11:25:08 -0500

    So, I believe a straightforward way to get back my shellinabox setup is to go back to version 1.1 of the openmediavault-shellinabox plugin. I tried "apt-cache policy openmediavault-shellinabox" and only version 1.2 is displayed.

    Does it make sense to go back to version 1.1 and if so, how do I go about reverting to version 1.1 of the plugin?

    Thanks in advance

  • I've figured out how to do what I was looking for.

    FYI, I think something like this may be needed for the mysql plugin. I seem to remember installing it a long time ago with no issues and then when I went to install it later there were some problems with the configuration/setup I had.

    In case anyone else is looking to do this or something similar, here's what I did.

    I found the 1.1 version of the openmediavault-shellinabox plugin and installed that locally/manually using dpkg:

    dpkg -i openmediavault-shellinabox_1.1_all.deb

    Results from "apt-cache policy openmediavault-shellinabox":2.14

    Installed: 1.1
    Candidate: 1.2
    Version table:
    1.2 0
    996 stoneburner-testing/main armhf Packages
    *** 1.1 0
    100 /var/lib/dpkg/status

    Following that, the installed version of shellinabox which is the latest available for me, worked fine:

    Installed: 2.14-1
    Candidate: 2.14-1
    Version table:
    *** 2.14-1 0
    500 wheezy/main armhf Packages
    100 /var/lib/dpkg/status
    2.14-1 0
    500 wheezy/main armhf Packages

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!