Rsync jobs to view in log file(s)

  • I have an OMV ver.2.2.14 server and in the Webgui under Service : Rsync


    I created Rsync jobs exp. Folder1 Folder2 and Folder3 jobs where rsync job for the Folder1 is set to run backup every Friday after 1 a.m.
    for the Folder2 is set to run backup every Saturday after 1 p.m. and for the Folder3 is set to run backup every Sunday after 1 p.m.


    I would like to view the logs files for these rsync jobs I created... I would like to periodically check if backup jobs been completed etc.


    Can you let me know if there is a way to do so? If yes, how can I do it so I could view logs files for these services I setup?


    Thank you,

  • To flmaxey,


    I did and this log is empty. Also when I did set up the Rsync job, I DID NOT select Suppress non-error messages option.
    I have to 2 Openmediavault server and I have the same problem on both? I don't know why?


    Any idea what is wrong?


    Thank you

  • In that case I would wonder if your Rsync Jobs actually ran.


    To manually run an Rsync job:
    Go to <Services>, <Rsync>, and click on one of your jobs and "run". A dialog box will open, then click "start".


    If the job is working, the dialog box will show you something like the following:
    (In my case, everything is up to date. If new files are copied, from the <source> to <destination>, the list will scroll by.)
    _____________________________________________________________________________
    Please wait, syncing </srv/e29e426a-9fde-458f-b398-b70108fff26e/> to </media/5eee31cc-c41b-46b4-b829-71951efd6bb5/ServerFolders/Backups> ...


    sending incremental file list


    sent 226,902 bytes received 1,001 bytes 9,302.16 bytes/sec
    total size is 6,568,917,731 speedup is 28,823.31
    _____________________________________________________________________________


    If you're not getting something like the above, the job is not working.


    BTW - what you see in this dialog window is also stored in the Rsync log.

  • To flmaxey,


    I had to enable Rsync server service and I see informations in the Rsync log when I run Rsync Job under Services : Rsync.
    So I enabled Rsync server service on both Openmediavault servers and it seems is working on both now.


    Thank you flmaxey

  • Hello friends of OMV :)


    I use this old thread, because it's title fits to my question ;)


    I created an rsync PULL job via scrip:


    Code
    rsync -ahv --delete --stats --log-file="/var/log/rsync.log" --log-file="/var/log/rsync_BACKUPS.txt" -e "ssh -p 222 -i /etc/ssh/openmediavault-06d0beb8-a3dc-4bde-a404-1092fc1810b3" MyUser@192.168.1.6::BACKUPS /srv/afece2ad-7c23-492c-a29c-69657c1f5d0d/Syno_Backups/BACKUPS/

    It pulls the BACKUP folder from my Synology NAS and puts it into the Syno_BACKUP Folder (UnionFileSystem) on my OMV machine.

    This worked like a charme.


    I create the second Logfile in this code (rsync_BACKUPS.txt) in txt format, because in the end of the script i send an status eMail with this txt attached.

    This works like a charme too.


    BUT: I can no longer see any logs in my OMV box interface.

    Wenn i take a look into /var/log/rsync.log, it is totally empty...


    Any ideas?

    Or is my syntax of creating two log files wrong?

    Would it be better to copy the rsync.LOG into rsync_BACKUPS.txt after the job finished?


    Thank U so far :)

    OMV 5.6.9-1 (Usul) // ASRock J5040-ITX // be quiet! ATX 500W (BN46) // 2x4GB Samsung M471A5244BB0-CRC

    Fractal Design Node 304 // 4-Port PCIE to SATA 3.0 ControllerCard // 1x 128GB SSD, 3x 4TB and 1x 5TB HDD

    Edited once, last by Kamikaze01 ().

  • It could be the multiple log files. Try this, do one log file and then follow it with a second command. If separated with a semicolon ; the copy command, from one log file to another, can be executed on the same line.

    I.E.

    rsync -ahv --log-file=/var/log/rsync.log SourceFolder/ DestinationFolder/ --progress ; rsync --delete /var/log/rsync.log /var/log/rsync_BACKUPS.txt

    On the other hand rsync logs append. I don't know how that would be handled on the destination side. It might be necessary to drop the delete switch and use wildcard characters.

  • thank u for the answer...


    yeah... seems as the second log in the syntac was the problem.


    i just use rsync with only one log file (rsync.log)

    Code
    rsync -ahv --delete --stats --log-file="/var/log/rsync.log" -e "ssh -p 222 -i /etc/ssh/openmediavault-06d0beb8-a3dc-4bde-a404-1092fc1810b3" MyUser@192.168.1.6::BACKUPS /srv/afece2ad-7c23-492c-a29c-69657c1f5d0d/Syno_Backups/BACKUPS/


    in in the end of my script, bevor sending the mail is simple make

    Code
    cp /var/log/rsync.log /var/log/rsync.txt



    Problem solved for me :)

    Thank u for help

    OMV 5.6.9-1 (Usul) // ASRock J5040-ITX // be quiet! ATX 500W (BN46) // 2x4GB Samsung M471A5244BB0-CRC

    Fractal Design Node 304 // 4-Port PCIE to SATA 3.0 ControllerCard // 1x 128GB SSD, 3x 4TB and 1x 5TB HDD

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!