Upgrade to 3.x and grub error as a result

  • Hi guys,
    sorry to bother you...
    After over a year I tried to upgrade from the latest 2.x to 3.x (with the omv-release-upgrade command).
    The only plug-in I have installed is Snapraid.
    Unfortunately after many attempts I have the same "grub" error console.
    If there is a guide about it, please point me there... :)

    Here the system info

    Thanks in advance for your help!

  • Any help to debug my issue ?
    I have executed these commands:

    apt-get update
    apt-get dist-upgrade

    After the reboot i get the grub rescue console.

    There is a way to log what happen during the command "omv-release-upgrade" ?

    Every time I have to restore the clonezilla image of my system drive because it will not boot... :(

    Any advise is welcome... Tnx!

  • I have run into the same problem as you have in trying to upgrade 2.2 .x to 3.x. The only way I was able to solve it was to take the OMV drive to another Linux machine and reinstall grub to the OMV disk from there. There are numerous HOWTOs out there that describe the procedure - just google "boots to grub rescue"

    Once that was done and the OMV drive taken back to its own machine it did boot, but had so many other problems that I was convinced that, in my case, OMV could not be upgraded from 2.2.x to 3.x. I am still on 2.2.x.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

    Edited once, last by gderf ().

  • I wanted to upgrade my OMV as well so, what I did:
    1. apt-get update; apt-get upgrade; apt-get dist-upgrade
    2. omv-update (it's probably the same as that above, any way I've done that 2)
    3. omv-release-upgrade (it's took a while), after that
    4. dpkg -r openmediavault-omvextrasorg
    5. next I followed the instructions from http://omv-extras.org/joomla/index.php/guides:
    # wget http://omv-extras.org/openmedi…extrasorg_latest_all3.deb
    # dpkg -i openmediavault-omvextrasorg_latest_all3.deb
    # apt-get update
    6. reboot the system and...
    That worked fine 4 me.

    "Given enough eyeballs, all bugs are shallow"

    Edited 2 times, last by Jap0 ().

  • Hi guys.

    I have solved by a combination of the two advices.

    To solve the grub error I have reinstalled grub with the "Parted Magic" distro.

    Firstly identify your boot drive with the "Parted Magic Mount" utlity.
    In my case was :"/dev/sdf1"

    then, from the main menu select:
    -Boot Utilities
    -Boot Loader Restore Utility

    Install the new grub on (in my case...) "/dev/sdf1".

    After that my OMV box booted fine... but the web interface was not accessible...

    To solve this issue:

    wget omv-extras.org/openmediavault-omvextrasorg_latest_all3.deb
    dpkg -i openmediavault-omvextrasorg_latest_all3.deb

    after that, reboot the machine.

    Now the web interface is accessible.

    There are still some minor quirks (that i will investigate later on), but after all the machine works-ish :)

    Thank you guys!

    Let me know if I could do it in a better way... specifically, someone with a real knowledge about the "grub" command
    has an alternative method (without using "Parted Magic") to solve the issue ???

  • My upgrade also resulted in error:

    Errors were encountered while processing:
    Creating index of upgradeable packages ...
    Creating index of openmediavault plugins ...
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Boot in rescue mode:

    grub rescue >
    set prefix=(hd0,1)/boot/grub
    set root=(hd0,1)
    insmod linux
    insmod normal

    Reboot and finish upgrade:

    aptitude upgrade
    aptitude safe-upgrade

    Reinstall grub (in my case /dev/hdc is the root-Device):

    grub-install /dev/hdc

    Finish omv-release-upgrade:


    The following problems still exists after upgrade:

    • Notifications

      E-Mail Sender not set (header "From: <sender>" missing) by OMV-Notifications

    • Each time you login via webinterface, you get an (unwanted) email notification
      (this can not be configured)


    Michael ^^

    omv 4.1.8 (Arrakis) | Debian 9.4 (stretch) | Kernel 4.9 | Intel Celeron J1800 | MX-ES 8GB USB 3.0 | RAID1 1TB

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!