Emby in Docker : impossible to read folder to update library

  • Hello,

    I upgraded to OMV 3.0, and just installed Docker. I want to use a Emby container which will take care of my movies and TV series.
    In OMV, I have got two folders : one for movies and one for series. So, I configured the container to access these folders like this :

    However, when I run Emby and configure it to point on my movie and TV folders, nothing is scanned. It seems it is a problem of read/write access ; this is weird because I enable the access of my folder for docker. What is wrong?

    Best regards,

    PS : I also tried with Plex, and the same problem occur.

  • Hi

    I've had a similar issue and posted it on the Emby Forums, seems that Emby has a local copy of ffmpeg which needs suitable permissions to execute. If you have put the /config folder on a OMV Share then this execution is denied as the FSTAB record is set to NOEXEC.

    Does that make sense?

    I have an separate SSD which holds docker and all the application data, so just remove noexec from the fstab entry for that drive.

  • @kentish is spot on. This "noexec" on the data drives in /etc/fstab is an issue we've seen with many things. The defaults when a data drive is added by OMV to fstab is to have it "noexec" for security purposes. If something nefarious were to get on your system this would possibly help to protect your data.

    With the emby plugin I moved the files that needed to be executed to the system drive and left symlinks in the location where it resided on the data disk. Hopefully I'll get this plugin updated soon for OMV 3.x.

  • Yes I thought it was a security thing and for some reason I forgot that you could use symlinks to link to the binaries :whistling:

    That would be nice as I had some issues with emby in docker, DLNA only works in host mode and for some reason I can't seem to access it outside my lan. Saying that I'm not hijacking an old thread and asking for help just passing comment ;)

  • There's no need to do any of that...just add Emby to Docker, run it, then configure Emby from a web browser, the only option I changed was the user and changed that to Emby. The more recent Emby distros now an ffmpeg added, there seemed to be some confusion and errors regarding adding ffmpeg during the setup wizard process.

    You then have to be careful where the metadata is stored, I have a share that setup for that.

    TBH I never thought of adding the shares within the container. I don't use Docker now I use apt-tool to install Emby.

  • If you want DLNA or similar services you should have a look at using the macvlan network driver in docker. It allows you to give a container its own ip. Support for macvlan should be coming "soon" to the docker plug-in.

    Swapping the docker to host mode resolved the DLNA issue but I am interested in looking a Macvlan. I'd also consider just installing emby via apt-get but it's working now so have to resist the temptation to mess as I'll only break it ;-)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!