Intel Apollo Lake Mo Installation Tips

  • It seems that people are still having problems with the installation process of OMV 3.x (being really REALLY slow) on Intel Apollo Lake platforms. I figure I should write this down so people don’t have to get their hands dirty moving drives around/changing bios settings like crazy just to get through the installation.

    I guesse the problems were caused by both the iGPU and the power management, so I tried to change some of the boot parameters of the installer, with a ASRock J3455-ITX board (nothing's attached to the board besides two memory sticks, a 64G SSD, a VGA monitor and a USB keyboard):
    1. change "vga=xxx" to "vga=normal" followed by "fb=false"
    2. add "acpi=off" after "fb=false"

    Well you won't have a nicely-placed UI with "vga=normal" and "fb=false" but the UI will still be usable.
    I only tested with all three modifications in place and they granted me a nice and easy installation but I'm thinking "acpi=off" along should do the trick... you are welcome to try it out. :D

    The installer was trying to configure the NICs when I started writing this and by now the installation is done, so you have some idea about how smooth things can be. :D

  • Hi there!

    I can confirm that the acpi=off option does the trick

    I had the typical Apollo Lake slowness issue for install - the extra option solved it and allowed me to install OMV 3.0.86 without issues :)

    As you had anticipated, no need to add vga=normal and fb=false!

    Here's what I did

    • In BIOS, turn on CSM (Compatibility mode)
    • Make a bootable OMV USB using unetbootin
    • Once the drive was done, edit the syslinux.cfg file at the root of the USB stick
    • For the boot option you intend to use (typically Default under label unetbootindefault), inside the append line, insert acpi=off (I placed it right next to vga=xxx)

    My configuration :

    OMV 3.0.86

    ASRock J4205-ITX
    4 GB RAM
    60GB SSD as system drive (Drevo)
    2 x 3.5" Seagate IronWolf 3TB
    Nothing plugged in except power, keyboard, USB stick and network

    Thanks zzz09700! I hope the above is useful to less experienced users :)

  • Thx you guys I passed the installation. But omv forget my raid after every reboot. I also have trouble with SMBus during the boot process.
    Did you guys face these problems? How did you solve them?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!