Windows shares / samba Trouble shooting

  • Windows 10 gives errors trying to connect to a omv samba share
    I am trying to make a generic thread. Please start your own thread specific to your OMV. When you create it please provide as much info as possible. Such as OMV version, os versions or broke after xyz update etc.


    Other trouble shooting tips are welcome as I don't know all.


    I have been seeing lots of posts with sharing problems. I have not been able to replicate them so am just posting what I would do if I could replicate.


    Putty is a good tool to allow windows to ssh to your OMV server. ssh is enabled by default on newer versions. I can't remember what version it started at so you ma need to enable it from the gui. The code tags below are cut and pasted from putty. Putty will give you a remote cli on your windows machine.


    Do the easy stuff first.

    • Disable windows firewall, till you get it working.
    • Use ip addresses so dns is not involved.
    • Be sure the workgroup is the same. Set the domain to the workgroup name.
    • Check the network type configuration in windows (public, work or home). I think public disables netbios.
    • Be sure you can ping your OMV from windows and ping windows from OMV.
    • Make sure the time is set on both. Windows does weird things if they are not close enough.
    • Try to connect to OMV from as many devices as possible, phone, kodi box, ipad, linux etc.
    • If any connects or at least asks for a user password samba is probably running. If so look at sharing settings and rights on OMV.

    Good info here. For help with seeing OMV shares in Windows 10, see this -> HOW TO.







    By default samba logging is set to none. Set it to full or debug and remember to set it back once you get it running. nano /var/log/samba/log.samba to read it or tail -f /var/log/samba/log.samba to see it in real time.




    If nothing asks for a user name samba may not be running. To test it try at the cli.


    root@omv3:~# systemctl status smbd Should look something like this.


    Code
    root@omv3:~# systemctl status smbd
    ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
    Loaded: loaded (/etc/init.d/smbd)
    Active: active (running) since Fri 2017-06-23 14:06:47 MDT; 1 day 20h ago
    Process: 1007 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/smbd.service
    └─1048 /usr/sbin/smbd -D
    Notice: Active: active (running) since

    If you see Fake start-stop-daemon called see Windows shares / samba Trouble shooting


    Another way to see if it is running. root@omv3:~# ps aux |grep smb



    Code
    root@omv3:~# ps aux |grep smb
    root 1095 0.0 0.3 291876 14040 ? Ss 14:09 0:00 /usr/sbin/smbd -D
    root 2342 0.0 0.0 12732 2224 pts/0 S+ 15:39 0:00 grep smb

    If smbd is running make sure nmbd is also running. This is very important as this is the binary that makes the announce to windows possible. In Jessie Debian ships this as two separate systems units. systemctl status nmbd




    Code
    root@omv3:~# systemctl status nmbd
    ● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
    Loaded: loaded (/etc/init.d/nmbd)
    Active: active (running) since Sun 2017-07-02 08:58:13 MDT; 1 day 10h ago
    CGroup: /system.slice/nmbd.service
    └─3636 /usr/sbin/nmbd -D

    If they are not running we need to figure out why. Post a thread with as much detail as you can.


    If they are both running, try to connect with a cli tool. Like powershell on windows or ssh on others.


    Have a look at this thread for windows permissions. https://forum.openmediavault.o…?postID=158823#post158823


    To be continued.

    If you make it idiot proof, somebody will build a better idiot.

    Edited 10 times, last by donh: Incorporate suggestions from below. ().

  • I like the idea!!!


    Some proposals:

    • change tag from OMV0.3 to OMV3.0 (otherwise reader might think it is outdated)
    • use a list (like this one, or with numbers might be even better), so it is more easy for the reader to see which topics belong together; also it becomes like a checklist, so that the individual topics can be checked one by one
    • pin the thread
    • trouble shooting tip: (temporarily) disable any firewall to check if the firewall is blocking the traffic


  • Good points, thanks. May pin it after a little more feed back. I will modify the first post so people don't need to read the whole thing. But leave things to give credit to those who contribute.


    Other moderator please feel free to edit my first post as I may be awol from time to time.


    Thanks

  • I think what you are trying is admirable, having spent nearly a day myself trying to get my W10 machine to 'see' omv on the network. But before I used omv I was using nas4free and W7, when I moved to W10 nas4free disappeared...that prompted my change to omv plus omv appeared to do more.


    However, getting back to the point in hand, yesterday I installed Mint xfce on an old laptop to test something under wine, needless to say I decided to check out my network on W10, and it couldn't see Mint xfce. So going through the usual I could ping mint form w10 by ip or it's hostname, the same from mint, so in essence they were on the same network/subnet.


    Most home users will use a router which takes care ip adressing because it issues that through dhcp, and if you do an ipconfig /all on windows box it display all the relevant network info, ip address, default gateway, dns. Windows uses the workgroup to connect home computers together, however, this needs to be set up, so does network discovery and file and print sharing, with all this done they can happily play together.


    My Mint Cinnamon laptop could 'see' my windows network but could not communicate, my windows machines didn't even know cinnamon was there (they did from a ping request)....cinnamon adds and picks up dns from the router so that's one step out the way. Until I installed Samba and added the windows workgroup name cinnamon could be seem by my windows machines, I could use file explorer in windows and add the ip address or hostname of the cinnamon laptop for it to be displayed.


    Back to mint xfce, in it's network info it displays, ip address, subnet mask and b'cast info, nothing else....however, xfce comes with a network tool which you have to unlock to edit, so under domain add the windows workgroup name, under dns add my router ip as this is the dns for the home network.....and as if by magic mint xfce appears under windows network. Prior to these changes if I used the ip address or the hostname of mint xfce in windows file explorer you get an error message pop up....windows doesn't know about it, if can't find it...so what to change on a windows machine.


    Control Panel>>>Networking and Sharing Center ensure that Network discovery is turned and if necessary file and print sharing this is done under Advanced sharing settings. Back to Network and Sharing click on connections this will either be Ethernet or Wireless, Click on Properties, Select (TCP/IPv4) and click on properties, bottom right hand corner click on advanced, selecl the WINS tab and you will see the NetBIOS setting this is always set to Default and if you read the info it needs changing to the option Enable NetBIOS over TCP/IP.


    So if you have done all that on your windows machine omv will require changes to the network settings: Domain name needs to be the same as the windows workgroup, click save then apply changes, under interfaces double click on the network displayed (mine is eth0, scroll down and under dns settings add the dns which is usually your router but check your windows machine.


    If all that is set OMV should appear on the windows network, if not you should at least be able to use OMV's ip address or hostname from within file explorer without a network error....this was so much simpler in the days netbeui.


    Samba should then be straightforward to set up.....however in respect of W10 this has thrown a number of curve balls and it's MS that's at fault, you may have to ensure that SMB1 and SMB2 are running even though W10 is supposed to use SMB2/3.


    I have commented on a couple of threads regarding this along with a link and some registry changes....I can't stress enough that this is an MS issue not OMV or Samba.


    EDIT:


    W10 has issues if you use an MS login or a PIN personally I use a local login.


    This is also appearing quite a bit as a possible solution;


    1/ run cmd as admin
    2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    3/ sc.exe config mrxsmb20 start= disabled
    Restart and you are done!


    Another option is to add credentials, Control Panel>>>Credential Manager>>>Windows Credentials some people find that this works.


    There is also this a post by Fireboss and editing the local group policy.

  • Thanks for the input. Maybe you could start a similar thread for win10 to be linked above. A few of the threads I have seen samba was probably not running. I think some may give up and move on to some other thing. My goal is to keep the first post simple with links to other resources. And not have to keep reading many threads to find the latest info. It may turn into a wiki or something down the road, who knows.

  • I can recall a couple in my head about not seeing the server in the network section, don't use windows any more.


    • Make sure the workgroup is the same in windows as configured in the samba server.
    • Check the network type configuration in windows (public, work or home). I think public disables netbios.
    • If smbd is running make sure nmbd is also running. This is very important as this is the binary that makes the announce to windows possible. In Jessie Debian ships this as two separate systems units.
    • Another samba server in the network. If you have an openelec/libreelec or any other server also using samba in the same network segment, turn it off temporarily.

    @donh once you have everything we can consolidate at the guide section.

  • I cannot see OMV on the network, or get to the shares.


    Windows 10 Pro 64bit (of course)




    I had OMV ver 2.xx install for the last 2 years or so, worked great....
    Until the os drive started to fail. It is an old 40gb laptop drive in a USB case.


    So...I got a new 160GB drive - installed into a new usb-3 case and installed OMV 3.0.88


    After doing the upgrades, it says now that it is ver 3.0.89




    I have re-installed 3 times (4 times total) and have not been able to see OMV on the network or access any of the shares.


    The last install, I followed the video exactly. It was pretty much what I was doing before. No help.


    I can access the web gui. I can ping OMV. I havn't tried SSH because the 2 machines are side-by-side right now and I have a kbd and monitor on the OMV machine.



    Setup:
    Asrock Mini-ITX N3700 mobo with only 4 SATA ports (that's why I'm using a USB hard drive for the os drive)


    16gb ddr3 laptop memory - was used for z-raid in the 2.xx version, but I don't have the z-raid set up on the new 3.xx version of OMV.


    It is a nice machine that only uses 7 watts when idle - yet it is a quad core, 64 bit pentium based cpu that easily serves files and transcodes media.


    I have 4 - 1tb 2.5" hard drives installed for data. Not in raid this time. Formatted as EXT4.


    3 of the drives have 1 share folder set up each.


    The 4th drive is used for media and has 2 share folders - TV and MOVIES.


    I have not installed the OMV Extras yet. Just want to get the drives working first.



    Drives are mounted.


    Samba is turned on.




    I have 3 windows machines in the house, the other 2 are windows home laptops. None of them can see the OMV nas.


    I do have a Mint linux machine, but no monitor on it and havn't used it for 6 months or so. Could start it up to see if it can see the OMV shares.




    I have gone through most of the stuff in the forum above for my win10 machine.


    I have created credentials on windows.

  • I cannot see OMV on the network, or get to the shares.


    Windows 10 Pro 64bit (of course)




    I had OMV ver 2.xx install for the last 2 years or so, worked great....
    Until the os drive started to fail. It is an old 40gb laptop drive in a USB case.


    So...I got a new 160GB drive - installed into a new usb-3 case and installed OMV 3.0.88


    After doing the upgrades, it says now that it is ver 3.0.89




    I have re-installed 3 times (4 times total) and have not been able to see OMV on the network or access any of the shares.


    The last install, I followed the video exactly. It was pretty much what I was doing before. No help.


    I can access the web gui. I can ping OMV. I havn't tried SSH because the 2 machines are side-by-side right now and I have a kbd and monitor on the OMV machine.



    Setup:
    Asrock Mini-ITX N3700 mobo with only 4 SATA ports (that's why I'm using a USB hard drive for the os drive)


    16gb ddr3 laptop memory - was used for z-raid in the 2.xx version, but I don't have the z-raid set up on the new 3.xx version of OMV.


    It is a nice machine that only uses 7 watts when idle - yet it is a quad core, 64 bit pentium based cpu that easily serves files and transcodes media.


    I have 4 - 1tb 2.5" hard drives installed for data. Not in raid this time. Formatted as EXT4.


    3 of the drives have 1 share folder set up each.


    The 4th drive is used for media and has 2 share folders - TV and MOVIES.


    I have not installed the OMV Extras yet. Just want to get the drives working first.



    Drives are mounted.


    Samba is turned on.




    I have 3 windows machines in the house, the other 2 are windows home laptops. None of them can see the OMV nas.


    I do have a Mint linux machine, but no monitor on it and havn't used it for 6 months or so. Could start it up to see if it can see the OMV shares.




    I have gone through most of the stuff in the forum above for my win10 machine.


    I have created credentials on windows.

  • All of these:


    Do the easy stuff first.

    • Disable windows firewall, till you get it working.
    • Use ip addresses so dns is not involved.
    • Be sure the workgroup is the same. Set the domain to the workgroup name.
    • Check the network type configuration in windows (public, work or home). I think public disables netbios.
    • Be sure you can ping your OMV from windows and ping windows from OMV.
    • Make sure the time is set on both. Windows does weird things if they are not close enough.
    • Try to connect to OMV from as many devices as possible, phone, kodi box, ipad, linux etc.



    root@crownas:~# systemctl status smbd
    ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
    Loaded: loaded (/etc/init.d/smbd)
    Active: active (exited) since Sat 2017-10-21 10:20:26 CDT; 2h 53min ago


    Oct 21 10:20:26 crownas smbd[6955]: Starting SMB/CIFS daemon: smbd
    Oct 21 10:20:26 crownas smbd[6955]: Warning: Fake start-stop-daemon called, doing nothing.
    Oct 21 10:20:26 crownas smbd[6955]: .
    Oct 21 10:20:26 crownas systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).



    getting more

  • root@crownas:~# systemctl status nmbd
    ● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
    Loaded: loaded (/etc/init.d/nmbd)
    Active: active (exited) since Sat 2017-10-21 10:20:27 CDT; 3h 2min ago
    Process: 7005 ExecStart=/etc/init.d/nmbd start (code=exited, status=0/SUCCESS)


    Oct 21 10:20:27 crownas nmbd[7005]: Starting NetBIOS name server: nmbd
    Oct 21 10:20:27 crownas nmbd[7005]: Warning: Fake start-stop-daemon called, doing nothing.
    Oct 21 10:20:27 crownas systemd[1]: Started LSB: start Samba NetBIOS nameserver (nmbd).
    Oct 21 10:20:27 crownas nmbd[7005]: .

  • Did this:


    Control Panel>>>Networking and Sharing Center ensure that Network discovery is turned and if necessary file and print sharing this is done under Advanced sharing settings. Back to Network and Sharing click on connections this will either be Ethernet or Wireless, Click on Properties, Select (TCP/IPv4) and click on properties, bottom right hand corner click on advanced, selecl the WINS tab and you will see the NetBIOS setting this is always set to Default and if you read the info it needs changing to the option Enable NetBIOS over TCP/IP.


    So if you have done all that on your windows machine omv will require changes to the network settings: Domain name needs to be the same as the windows workgroup, click save then apply changes, under interfaces double click on the network displayed (mine is eth0, scroll down and under dns settings add the dns which is usually your router but check your windows machine.


    No change. Still not seen on network.

  • Fake start-stop-daemon called looks suspicious. Should look more like this





    Look at this.https://lists.debian.org/debian-user/2002/12/msg00965.html


    When you did the install, did it ask to reboot? Or did you have to manually reboot?

  • I think it may have still running scripts but may have hung up. Don't know how to tell what might be hanging it. Not to scare you but I also don't know if anything else could not be set up.


    Did you try the sugestion from that link?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!