Mini DLNA Ignore my files

  • Why is your interface commented out in your /etc/minidlna.conf file???


    Code
    #network_interface=eth0

    Your config file should have the network interface set to whatever your OMV is using, there should not be #:


    e.g. if your OMV is eth0
    network_interface=eth0


    e.g. if your OMV is using eth1
    network_interface=eth1

  • I certainly can change this line. But the bottom line is that I can connect to it, I can not see the files. I see DLNA service in my network, I can connect to them.

  • The root of the disk has closed permissions for other and some acl. Do you really use acl? Or were you fiddling around and it got messed up like that ?
    You can use the reset permission plugin to clean all acl and default permissions.


    Anyway try this first see if it fixes.


    chown root:root /srv/dev-disk-by-label-Files
    chmod 755 /srv/dev-disk-by-label-Files/

    You GOD, thx its help me. Very nice. Thx thx thx. The best


    Write to me in private messages, I will send you routeros lisence or little cash to you card for you choice.

  • Hi,



    i have a similiar issue, which i was not able to solve yet.



    My setup:


    * shared folder '10_Work'
    * shared folder '21_Archiv'
    * user 'omv' for accessing those stuff from my mobile devices (laptop, ipad, android phones)
    * both shared folders have the same permissions and user/group in filesystem
    ** folders: drwxrws---, omv:users
    ** files: -rwxrwx---, omv:users
    * user 'omv' has read/write access to folder '10_Work' and read only access to '21_Archiv'

    After switching from OMV2 to OMV3 a few weeks ago, i had an issue accessing the folder '21_Archiv' from my laptop. I fixed this by chmod/chown recursiv over the two folders to the settings above. User 'omv' is now allowed to read/write the '10_Work' folder and has readonly acces to '21_Archiv'. Before doing that, the user/group was root:root.



    Now the problem:
    * installed the miniDLNA plugin
    * added the share for '10_Work' -> this works pretty fine, i can access media (music and photos) with bubbleUPNP app on android phones
    * added the for '21_Archiv' -> this works not. While scanning, the minidlna log says 0 files, allthough there should be thousands of photos on this share

    My first assumption was, that there something most be wrong with the permissions, but they are the same for both folders, as shown above.



    What could be my Problems, the log while scanning shows no errors for me.



    Please let me known, which informations you need. I don't wan't to set root:root, as described above, as this made problems while accessing those shares via smb from windows.


    The network_interface was commented by default, i didnt changed anything on this file. But it works for my '10_Works_Folder'



    Code: minidlna.log
    [2017/08/10 09:59:23] minidlna.c:154: warn: received signal 15, good-bye
    [2017/08/10 09:59:25] minidlna.c:1034: warn: Starting MiniDLNA version 1.1.6.
    [2017/08/10 09:59:25] minidlna.c:344: warn: Removed media_dir detected; rescanning...
    [2017/08/10 09:59:25] minidlna.c:1074: warn: HTTP listening on port 8200
    [2017/08/10 09:59:25] getifaddr.c:338: info: Enabling interface 192.168.178.10/255.255.255.0
    [2017/08/10 09:59:25] scanner.c:726: warn: /srv/dev-disk-by-id-md-name-omv-0/21_Archiv wird gescannt ...
    [2017/08/10 09:59:25] scanner.c:815: warn: Scan von /srv/dev-disk-by-id-md-name-omv-0/21_Archiv abgeschlossen (0 files)!
    [2017/08/10 09:59:25] playlist.c:125: warn: Parsing playlists...
    [2017/08/10 09:59:25] playlist.c:259: warn: Finished parsing playlists.
    [2017/08/10 09:59:26] inotify.c:199: warn: WARNING: Inotify max_user_watches [8192] is low or close to the number of used watches [2] and I do not have permission to increase this limit.  Please do so manually by writing a higher value into /proc/sys/fs/inotify/max_user_watches.

    I can also explain this in german, if this would be better.


    Thanks Joe

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!