Fresh 3.0.86 installation with broken Update Management

  • I just set up a new virtual machine with a fresh installation of 3.0.86. All I've done is configure the network and web admin password using omv-firstaid. Immediately upon entering the UI, I checked for updates and found many seemingly unnecessary firmware updates for my system. Since it was a brand new install I tried selecting all and upgrading anyway, which didn't work with a broken packages notice. Any reason why this version would cause this behavior?


  • Thank you for your response. The error still persists after running those commands.


    After apt-get -f install, the output indicates that the firmware and firmware non-free packages were kept back.


    Any reason this would come up on 3.0.86 but not 3.0.82 using the exact same virtual machine settings? I'd installed 3.0.82 nearly a dozen times and never had this issue.

  • OK looks good


    Try to Install (update ) the Firmware for the Both


    The best way (in my opinion) is to try it via Synaptics


    I'm not familiar with how to do this. Isn't Synaptic a GUI-only manager? Or is there another Synaptic?


    Edit - Also, is there a reason why it's showing upgrades for devices I don't have installed? Isn't it only supposed to update firmware that's relevant to my system?


    Edit 2 - Actually, I updated everything EXCEPT those two packages in Update Manager, and afterwards checked for additional updates, and those two no longer appear. Not sure what happened there, but now OMV says it is fully updated.

  • Edit - Also, is there a reason why it's showing upgrades for devices I don't use?

    i dont know why ... but thats the problem for now

    I just set up a new virtual machine with a fresh installation

    and thats the second :)



    My mistake .. its called Synaptic and not Synaptics


    https://help.ubuntu.com/community/SynapticHowto


    but the problem is another one .. I understand you have only install OMV ( from the .Iso) .. thats Work great but maybe is a problem for Virtual Machines


    i suggest you to install a debian 8 (jessie) on the Virtual machine .. (update + upgrade) if you are done and all works .. install OMV 3

  • but the problem is another one .. I understand you have only install OMV ( from the .Iso) .. thats Work great but maybe is a problem for Virtual Machines


    i suggest you to install a debian 8 (jessie) on the Virtual machine .. (update + upgrade) if you are done and all works .. install OMV 3


    You are right, I installed on a VM from the 3.0.86 iso. However, I had done the same thing many times with 3.0.82 and I never had this problem. That is why I thought it was strange and maybe something in the new version was broken.


    For now I am going to keep working with it as-is. I am just testing for a while before I decide to install on my actual server. Thank you very much for your time.

  • Here the Cangelog betwen 3.0.82 -3.0.86 (maybe helps)


    openmediavault (3.0.86) stable; urgency=low



    * Update locales.
    * Various improvements in the WebUI.
    * Fix bug in omv-initsystem.
    * Fix bug in /etc/smartd.conf.
    * Mantis 0001788: Support all time zones including backwards compatible.
    * Mantis 0001790: Make S.M.A.R.T. scheduled jobs sortable by device.



    -- Volker Theile <volker.theile@openmediavault.org> Mon, 24 Jul 2017 22:03:00 +0200



    openmediavault (3.0.85) stable; urgency=low



    * Update locales.
    * Various improvements in the WebUI.
    * Display auto network interfaces (e.g. bonded and vlan interfaces) in the
    CLI welcome message.
    * Set a maximum value for the MTU on the WebUI.
    * Allow browser caching WebUI CSS/Javascript/Images.
    * Add Xen virtual disk storage backend.
    * Mantis 0001772: S.M.A.R.T. WebUI shows red light, but all is green when
    open S.M.A.R.T. details.
    * Mantis 0001777: Memory leak when calling Guru Meditation window.
    * Mantis 0001781: Increase granularity on SSH "Permit root login" setting.
    * Mantis 0001782: BTRFS multi device listing is wrong formatted.



    -- Volker Theile <volker.theile@openmediavault.org> Mon, 17 Jul 2017 17:55:39 +0200



    openmediavault (3.0.84) stable; urgency=low



    * Various improvements in the WebUI.
    * Get correct CPU information for NanoPi NEO 2.
    * Improve handling of inactive logical volumes.



    -- Volker Theile <volker.theile@openmediavault.org> Tue, 11 Jul 2017 22:27:28 +0200



    openmediavault (3.0.83) stable; urgency=low



    * Update locales.
    * Improve error dialog with long messages.
    * Fix bug in the Quota::set() RPC.
    * Mantis 0001773: UID_MAX and GID_MAX from login.defs not read.



    -- Volker Theile <volker.theile@openmediavault.org> Thu, 06 Jul 2017 15:39:07 +0200



    openmediavault (3.0.82) stable; urgency=low



    * Update locales.
    * Various improvements.
    * Make SNMP location and contact fields optional.



    -- Volker Theile <volker.theile@openmediavault.org> Mon, 26 Jun 2017 22:44:51 +0200

  • I ran apt-get install --reinstall openmediavault and everything installed successfully, I was prompted with the splash page showing to run omv-initsystem, which I did, and my web UI session wasn't even logged out, everything continued to operate fine. However, since those random firmware updates had already disappeared from the Update Management tab previously, I'm not sure how to confirm that the reinstall actually accomplished anything.

  • apt update


    Code
    https://pastebin.com/pKKhWUiK




    apt list --upgradable


    Code
    root@ratsvault:/# apt list --upgradable
    Listing... Done


    apt upgrade


    Code
    root@ratsvault:/# apt upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!