HP microserver Gen10

  • Using a

    root@nasGST:~# dmesg --level=err,warn
    [ 0.000000] ACPI BIOS Warning (bug): Optional FADT field Pm2ControlBlock has valid Length but zero Address: 0x0000000000000000/0x1 (20170728/tbfadt-658)
    [ 0.105157] sysfs: cannot create duplicate filename '/firmware/acpi/tables/data/BERT'
    [ 0.105188] ------------[ cut here ]------------
    [ 0.105200] WARNING: CPU: 0 PID: 1 at /build/linux-3RM5ap/linux-4.14.13/fs/sysfs/dir.c:31 sysfs_warn_dup+0x51/0x60
    [ 0.105201] Modules linked in:
    [ 0.105208] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.14.0-0.bpo.3-amd64 #1Debian 4.14.13-1~bpo9+1
    [ 0.105210] Hardware name: HPE ProLiant MicroServer Gen10/ProLiant MicroServer Gen10, BIOS 5.12 09/20/2017
    [ 0.105213] task: ffff9b99b59fc040 task.stack: ffffa9a000c88000
    [ 0.105218] RIP: 0010:sysfs_warn_dup+0x51/0x60
    [ 0.105220] RSP: 0018:ffffa9a000c8bdd8 EFLAGS: 00010286
    [ 0.105223] RAX: 0000000000000049 RBX: ffff9b99b6936000 RCX: ffffffffa3a4d248
    [ 0.105225] RDX: 0000000000000000 RSI: 0000000000000092 RDI: 0000000000000283
    [ 0.105227] RBP: ffffffffa3864cf5 R08: 0000000000000001 R09: 00000000000000f5
    [ 0.105229] R10: 0000000000000000 R11: 00000000000000f5 R12: ffff9b99b5bcb180
    [ 0.105230] R13: ffffffffa2e08880 R14: ffffffffa3ab2570 R15: ffff9b99b6932048
    [ 0.105233] FS: 0000000000000000(0000) GS:ffff9b99bec00000(0000) knlGS:0000000000000000
    [ 0.105236] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
    [ 0.105237] CR2: ffffa9a000d34000 CR3: 000000004b60a000 CR4: 00000000001406f0
    [ 0.105240] Call Trace:
    [ 0.105252] sysfs_add_file_mode_ns+0x10f/0x170
    [ 0.105259] acpi_sysfs_init+0x176/0x248
    [ 0.105266] ? set_debug_rodata+0x11/0x11
    [ 0.105270] acpi_init+0x1d0/0x361
    [ 0.105275] ? acpi_sleep_proc_init+0x24/0x24
    [ 0.105279] do_one_initcall+0x4e/0x190
    [ 0.105284] ? set_debug_rodata+0x11/0x11
    [ 0.105287] kernel_init_freeable+0x167/0x1e8
    [ 0.105292] ? rest_init+0xb0/0xb0
    [ 0.105295] kernel_init+0xa/0xf7
    [ 0.105298] ret_from_fork+0x1f/0x30
    [ 0.105302] Code: 85 c0 48 89 c3 74 12 b9 00 10 00 00 48 89 c2 31 f6 4c 89 e7 e8 a1 c9 ff ff 48 89 ea 48 89 de 48 c7 c7 40 1c 83 a3 e8 3a 76 e2 ff <0f> ff 48 89 df 5b 5d 41 5c e9 e1 71 f5 ff 90 0f 1f 44 00 00 41
    [ 0.105359] ---[ end trace 1124c71069e8d3d9 ]---
    [ 0.106747] [Firmware Bug]: HEST: Table contents overflow for hardware error source: 2.
    [ 0.207616] pnp 00:04: disabling [mem 0xfeb00000-0xfeb00fff] because it overlaps 0000:00:01.0 BAR 5 [mem 0xfeb00000-0xfeb3ffff]
    [ 2.210561] [Firmware Warn]: valid bits set for fields beyond structure
    [ 2.433078] usb: port power management may be unreliable
    [ 5.458411] sp5100_tco: I/O address 0x0cd6 already in use
    [ 7.096830] kfd kfd: error getting iommu info. is the iommu enabled?
    [ 7.096858] kfd kfd: Error initializing iommuv2 for device 1002:9874
    [ 7.097013] kfd kfd: device 1002:9874 NOT added due to errors

  • bonjour ,

    sorry my english

    HPE ProLiant MicroServer Gen10 X3216 8GB-U 4LFF NHP SATA 200W PS Entry EU Server

    SSD 32 Go
    4 disk 1 To WD red for RAID

    elbow oil ;)

    no start raid hardware

    Type :
    BIOS (Entitlement Required) - ROM système ;)
    Version :
    ZA10A320(12 oct. 2017)

    date 25/01/2017

    apt update apt dits-upgrade or open http:// ip openmediavault tih update full ;)

    install ----->ok
    GRUB_CMDLINE_LINUX_DEFAULT="amd_iommo=on iommu=pt quiet"
    GRUB_CMDLINE_LINUX="amd_iommo=on iommu=pt"
    /etc/modprobe.d/blacklist.confblacklist sp5100_tco
    ****restart 8o8o ****

    this problem access disk (https://wiki.debian.org/HP/ProLiant) :cursing::cursing:
    my solution temporaire for visible disk
    GRUB_CMDLINE_LINUX_DEFAULT="irqpool all-generic-ide "


    creat raid via openmediavault web
    validate system file

    change grub
    GRUB_CMDLINE_LINUX_DEFAULT="amd_iommo=on iommu=pt quiet"
    GRUB_CMDLINE_LINUX="amd_iommo=on iommu=pt"


    dmesg --level=err NULL :):):)

    please apt install less simplify

    install *** :D OK :D ***

    please :
    sav /etc/mdadm/mdadm.conf to key usb :love::love::love:

    for change machine or change (scratch os ) https://wiki.debian-fr.xyz/Raid_logiciel_(mdadm)install *** OK *** :saint::saint::saint:

    this problem suspend because hibernate or suspend for hp gen10 not acces or button problem for my
    my arm does not go through the walls ;)

    is possible :whistling::whistling::thumbup::thumbup::thumbup::thumbup:



    # Avoid suspend
    # Copyright: Copyright (c) 2010 Paulo J. S. Silva
    # License: GPL-2

    case "${1}" in
    exit 1
    exit 0

    sudo chmod +x /etc/pm/sleep.d/000_no_suspend.sh

    full test my hp gen 10 and until broken OS

    INSTALL *** OK *** very simplify

    thank you OPENMEDIAVAULT :):):):):):)

  • bonjour , soory my english

    not install

    Broadcom NX1 Online Firmware Upgrade Utility for HPE MicroServer Gen10 Server with Linux x86 and x64

    I do not know how to install an RPM except with alien

    but above all is it necessary to do it

  • HI,

    today i have bought the Gen10.
    I am to stupid to regg on the hp page.
    Is it possible that someone can send me the Bios files to update the bios under windows server?

    I have the UEFI Bios files, but in the shell, when i keyin flashbios.nsh i get an error-
    such as no internal or external command.

    Can anybody help me.

    Thanks Frank

  • I think the procedure suggested by quertz at page2 is the solution I have not tried I have a lot of problem with network.

  • Some page ago I have done a simple guide If you have the UEFI bios you should do

    • Download the zip file
    • Unzip to a USB key
    • Enable UEFI Boot
    • Reboot your HP and boot to embedded UEFI shell.
    • Select the target device with the downloaded firmware by
      you have to type "fs0:" and press enter. ("0" is the number of your target storage device number in UEFI shell).
    • Navigate inside the folder structure it is like a linux shell.
    • when you reach "flashbios.nsh" type the prgam name with extension in the shell and press enter, the firmware update will start.
    • cross your fingers ancient method destroy and write
    • After the process complete, power cycle your system for firmware update to take effect.
  • @ bbm
    Thank you very much.
    I was in the wrong folder, now all is fine.

    Only in UEFI mode my vga monitor has a signal, in Bios-mode no signal.

    I have send back the gen10 because the warranty only valid to november 2018.

    It was not possible (perhaps i am stupid) to register the gen10 so that i could download the bios.

    The HP support sites are terrible, i will never try it again.

    I will buy again, if the bugs are gone and the bios updates are available from others than HP.

  • Hello everybody,

    I'm also on the same train with the HP gen 10, mine is the entry level option (AMD X3216) but I've brought the total ram to 16GB ECC.

    I installed Debian stretch (9.3) from netinst image then added the repos for OMV 4 arrakis as suggested in the wiki, all on my trusty SSD (Samsung 850 pro)

    My experience so far has been very sub-par, I've added the non free firmware (firmware-linux) and installed a kernel from stretch backports (4.14.0-0.bpo.3-amd64), so that I can see text on my attached display (via DP to hdmi adapter).

    What annoys me the most is the fact the gui is basically unusable, after logging in via default admin I installed OMV-extras for arrakis and some plugins:

    unionfs (for mergerfs)

    My config has 4 WD red 3TB disks, after wiping them they are available for software raid via mdadm but fail to show up in every other plugin.

    I created ext4 filesystems on each disk via gui and everything seems ready but whenever I try the unionfs or snapraid plugins the "drive" list is basically empty.

    After debuging the web interface a bit I'm able to see all calls to rpc.php come back in "false" state and are empty, here's an example:


    With a "null" error I simply don't know how to debug this... looks similar to https://bugtracker.openmediava…t_bug_page.php?bug_id=666 but even more nasty since wiping doesn't change anything at all.

    I'm having similar problems in samba config, no drives there...

    I was able to configure mergerfs, snapraid and samba from the command line but I might restart from scratch and dump OMV entirely since it's not being very useful.

    Does anybody have a clue what might be causing these issues?

    Many thanks!


  • May I suggest to do the entire activity with OMV4 cd and add non free. My gui is working and system is stable (no lan section I have no time to investigate) In my config i have not useud union or snap I have used mdadm (via console i prefer) and gui is in line with it.

  • Thanks to you, I don't know if it is a bug or it is a problem the first thing i have done was update the BIOS.

    The warranty is a big big problem (THE SAME AS YOU less then a year of warranty) I had wrote to HP many times, with no response so IMO the support quality is at the lowest quality; but for this type of hardware I don't think HP will spend much of its time.
    HP for a strange reason don't publish firmware in public and the exchange is forbidden.
    Another thing is HP has its own "linux" and support RH only.

  • FYI, HPE released a new UEFI version, I've updated the post accordingly.

    The only fixes mentioned are something with the TPM module, which I do not even have. Otherwise they seem to have integrated the broadcom UEFI RAID gui (module). The upside of this is you do not need to run it from disk/usb anymore, the downside is no linux user ever needed the thing anyways.

    Otherwise nothing to report from my side - server runs fine (with disabled temperature monitoring), but I still haven't upgraded the RAM or anything else. ATM RAM is simply to expensive, still almost twice the cost of a year ago.


    Since you have 16GiB RAM, have you done some benchmarks? I'd really like to see some, because dual channel should help the CPU quite a lot.

    Two rules of success in life:
    1. Don't tell people everything you know.

  • Thanks.

    I have a problem with network card (0) and (1)

    1) At startup only one network card is up and running.
    2) With dhcp I can assign an IP to a network card
    3) with ip command I can enable the second network and add an IP addr to It
    4) If I use omv-firstaid it hangs
    5) If I use omv web interface i see no network0 listed and only network1 listed in dhcp which is inconsistent

    No upgrade of drivers.

  • Little step... I have rewrite form zero the /etc/network/interfaces now on boot all cards are UP ip is assigned via DHCP.
    OMV web interface is still out of sync

  • Hello,

    I need some help with this server and how to make it properly output video via diplayport to HDMI adapter.

    If I boot the server with the displayport to HDMI adapter, I got no signal at all. However, If I boot the server connected to both VGA and displyaport, after GDM is loaded I can see image in both screens.
    I've also tried to configure as the primary monitor the one that is connected to the display port and it works as long as VGA is connected and GDM loaded. After, while I have image in both screens, as soon as I remove the VGA cable the image disappears from the display port screen.

    My thoughts were that when the VGA cable is not connected, the server disables the GPU. So, I tried to set up the GPU to force on the BIOS, no luck either.

    I am not using Debian or openmediavault at the moment, I am using CentOS 7. But I ask this here, because it is the only place where I found a proper discussion about this server and its Linux config.

    If someone confirms that displayport to HDMI (without a VGA connection) works for openmediavault, I am happy to install it. But' i wouldn't like to have to reinstall my system just for testing


  • Some page ago I have done a simple guide If you have the UEFI bios you should do

    • Download the zip file
    • Unzip to a USB key
    • Enable UEFI Boot
    • Reboot your HP and boot to embedded UEFI shell.
    • Select the target device with the downloaded firmware by
      you have to type "fs0:" and press enter. ("0" is the number of your target storage device number in UEFI shell).
    • Navigate inside the folder structure it is like a linux shell.
    • when you reach "flashbios.nsh" type the prgam name with extension in the shell and press enter, the firmware update will start.
    • cross your fingers ancient method destroy and write
    • After the process complete, power cycle your system for firmware update to take effect.


    Can you please explain how did you succeed into flashing the BIOS of your GEN10?
    I am facing the same challenge, and want to upgrade from 290 to 340.
    However, when I try to run the script in the UEFI shell (am already in the fs5:> prompt, and also in the correct location where the script resides), I get an error that the script is not executable cannot be run.
    Also, you speak about flashbios.nsh. Is this smth. else that the flashbios.sh I have, coming from the "System_BIOS_v_ZA10A340_for_MicroServer_Gen10_Linux.zip" achive?


  • Inside my USB I have this


    I'll look inside the 340 version.

  • Ok the new version has to be installed under linux !!

    I suggest to install the 320 if you don't need the 340 specific features. (I don't know them)

    - Read realtime HW thermal alert again.
    - Change thermal alert's temp low limit to default value 0x81(-127).

    When updating the System BIOS from version A320 (or earlier) to version A330 (or later), the following system BIOS configuration settings will revert to their factory default values:

    • System time and date
    • Hard drive configuration
    • Boot device sequence
    • System passwords
    • Security setup
  • Great!
    Thanks for the info!

    I managed to install the A330, that the last one generated for the UEFI environment.
    Here is the link to the A320 one.
    Here is the link for the A330 one.
    in case anyone needs them; a login is however needed.

    I wonder, what version of Linux is HP referring to, when they provide the A340 version for download. For sure the realtime HW thermal alert sounds interesting.
    I tried it so far under their latest ClearOS - community (free) edition, but does not work.

  • Thanks for the 330 link i think redhat because it is one of the supported but I don't know i have Debian

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!