Windows clients can Read/Write but Ubuntu client can only Read

  • I can't seem to figure out why I am unable to write to mounted CIFS/SMB shares using my Ubuntu box. The same share folders are mounted to my Windows 10 PCs using the same account and it has have full read/write access. When I mount the same folders in Ubuntu with the same user I can only read.


    Every time I try to create a file or folder in the mounted CIFS/SMB folder I get permission denied. I can only create files or folders if I use sudo. I assume it must be a permission issue, but I am unsure what permissions I need to add in OMV. The user "media" has R/W permission to the folder. I have used the OMV extra tool to make sure to reset the permissions and remove ACL.


    Settings in OMV:





    line in /etc/fstab from Ubuntu box:

    Code
    # mount media download folder
    //nas2.lesl.pw/media /mnt cifs credentials=/home/mediauser/.smbcredentials,iocharset=utf8,rw 0 0


    output of df from Ubuntu box:


    Code
    Filesystem 1K-blocks Used Available Use% Mounted on
    udev 1006344 0 1006344 0% /dev
    tmpfs 204820 3252 201568 2% /run
    /dev/sda1 15349744 1652000 12894980 12% /
    tmpfs 1024092 0 1024092 0% /dev/shm
    tmpfs 5120 0 5120 0% /run/lock
    tmpfs 1024092 0 1024092 0% /sys/fs/cgroup
    //nas2.lesl.pw/media 6228303224 189799024 6038438664 4% /mnt
  • Sorry for the triple post. Please delete the extra posts. When I tried to post I kept getting the following error so I thought it failed and kept retrying:


    Fatal error: An error occured. Sorry.
    Information:


    ID: 1aba215ed6d70ce9ba4926bd2b2816da94f2a4f3
    Please send the ID above to the site administrator.
    The error message can be looked up at “ACP » Logs » Errors”.

  • Because your using fstab the mount is mapped to root. If you are using a desktop the the file browser should be fine. Otherwise use uid in the fstab line.
    That is described in the ubuntu wiki for mounting cifs.

    Thanks! That fixed the problem. I don't know how I missed the uid option when I was reading the wiki... I guess I shouldn't setup NAS while low on sleep. :(

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!