Failed upgrade

  • Upgrading from 2 to 3, omv-release-upgrade aborts with the following error. Any idea on how to proceed?


    Errors were encountered while processing:
    postfix
    bsd-mailx
    sh: 1: .: Can't open /usr/share/openmediavault/scripts/helper-functions
    E: Problem executing scripts DPkg::Post-Invoke '. /etc/default/openmediavault; . /usr/share/openmediavault/scripts/helper-functions; if omv_checkyesno ${OMV_DPKG_POSTINVOKE_PURGE_MAN}; then if [ $(ps w -p $PPID | grep -c remove) != 1 ]; then echo 'Purging man pages ...'; rm -rf /usr/share/doc/* /usr/share/man/* /var/cache/man/*; else exit 0; fi; fi'
    E: Sub-process returned an error code
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    • Official Post

    Something went badly and the openmediavault package itself was uninstalled. The OMV 2.x -> 3.x upgrade is very problematic (a big part is switching from sysvinit to systemd). We recommend a fresh install.

    omv 7.4.2-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!