OMV2 -> OMV3 -> OMV4 Upgrade - little bug and fix

  • Hi!


    Have a little box to play around. That box was still on OMV2.
    As I wanted to test OMV4 I decided to Upgrade it from 2 to 3 to 4.
    Went pretty good - just the last upgrade step - from 3 to 4 had a little problem.


    After a reboot I got the "502 Bad Gateway" error.


    After a quick look in the logs I discovered that nginx is trying to access php-fpm on a wrong socket.


    The file /etc/nginx/sites-available/openmediavault-webgui references to


    fastcgi_pass unix:/var/run/php-fpm5-openmediavault-webgui.sock
    after the upgrade. But it should reference to
    fastcgi_pass unix:/var/run/php-fpm-openmediavault-webgui.sock


    instead.


    Don't know where this happened on that upgrade path - but as OMV3 was accessible pretty normal I think it happened on the update from 3 to 4.


    regards
    Lukas

  • Just for the record. Did an upgrade from 3.0.88 to 4.0.5 on a RPi which worked flawlessly itself. After reboot "502 Bad Gateway" error when trying to access the UI. The above was not the culprit since:

    Code
    root@raspberrypi:~# grep fastcgi_pass /etc/nginx/sites-available/openmediavault-webgui
            fastcgi_pass unix:/var/run/php5-fpm-openmediavault-webgui.sock;


    I then simply called omv-firstaid --> Configure web control panel --> No settings change --> ok, web UI works now. Since I'm an idiot I forgot to make a snapshot to compare before/after. So asking for guidance now, maybe omv-firstaid keeps a log of changes?


    Edit: At least parts of the brain work still so I did the same again after omv-firstaid and now it looks like this:


    Code
    root@raspberrypi:~# grep fastcgi_pass /etc/nginx/sites-available/openmediavault-webgui
            fastcgi_pass unix:/var/run/php-fpm-openmediavault-webgui.sock;
  • After reboot "502 Bad Gateway" error when trying to access the UI

    This is fixed in 4.0.6 - https://github.com/openmediava…d37cb6e853ef57bb8bff1fe75. omv-mkconf nginx is basically called by omv-firstaid which corrects sock line you found.

    omv 6.0.42-2 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.23 | mergerfs 6.3.3 | zfs 6.0.11
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I just upgraded from OMV3 to OMV4, and I tried with above methods, but still can't access to the webpage.
    It showing a blank page.




    Code
    sudo omv-mkconf nginx
    
    
    Site configuration file 'openmediavault-pxe' is already enabled.

    Edit: I uninstalled Pxe, still same issue.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!