What is the correct way to automount a usb 3.0 external hard disk on an already running server?

  • As the title say, I'm trying to understand the correct way to auto mount a couple of hard disks mounted as ntfs and ext4 to a server already running, without the need to reboot (so I guess no fstab).


    I'm thinking to install usbmount package:

    Code
    usbmount/oldstable 0.0.22 all
    automatically mount and unmount USB mass storage devices


    I'm looking to be able to automount external hard disk of 1tb and up through usb2.0\3.0 to use in conjunction with usbbackup plugin and standalone to transfer files between omv and the hard disk.



    But it seems to not support ntfs out of the box (maybe achievable through the conf file)


    Am I missing some other way to correctly do it? I thought omv would automount by itself, for using it with usbbackup plugin, but it does not, it doesn't see my external hard disk at all if plugged through usb3.0.
    Any help on the matter would be very appreciated.

  • the usbbackup plugin does automount on plug, and unmount on job termination. Strange that it doesn't pick up. Does dmesg show the disk on plug?


    The other option would be to use autofs, which triggers the mount command on folder access. Obviously the disk needs to be present to work,

  • Hi @subzero79


    I tried to reboot omv and replug the external 1tb hard drive onto the usb 3.0 port formatted with ext4 once booted up.


    here's my lsusb and dmesg grep, strange enough lsusb shows as everything is empty


  • strange enough lsusb shows as everything is empty

    If this is not an USB-C port but type A you most probably simply should blame the guys who invented this crappy connector. Get some alcohol, get cotton swabs, clean the SuperSpeed data lines, try again. If it still not works, check/replace cables/connectors.


    Alternatively connect the external disk to an USB2 port, the mechanical design of the Hi-Speed data lines is magnitudes less error prone compared to the SS/SS+ type A mess.

  • @subzero79 and @tkaiser


    Now it's even more strange..I was playing around with the other usb ports...after I plugged it to the usb2.0 automount worked out...so I thought maybe was the 3.0 usb damaged so I plugged it back to the 3.0 and now lsusb shows it aswell on the same 3.0 even so does usbbackup plugin ?(


  • I thought maybe was the 3.0 usb damaged

    You didn't answer whether it's a type A or C receptacle. At least I consider USB3-A being broken by design, it's a constant source of trouble, just search the forum for 'USB3 receptacle crappiness' ;)


    Please take this seriously, I would expect your next post dealing with 'xhci reset' dmesg output and maybe already data corruption.

  • @tkaiser sorry I just forgot to answer your question it's a type A usb, the hardware on that server is not really ultimate generation :D so type c unfortunately is excluded.


    I'm taking it seriously by the way don't worry I'm looking up what you posted


    Little edit:


    I think I found out what's going on, the external usb hard drive is one with an external power aswell, I noticed that if I FIRST plug the usb in and then Turn the switch on it works, it doesn't if I first turn it on and then insert the usb into the port...does it make any sense?


    I didn't thought about that because all my external hard drives are self powered through usb port but this one.
    But shouldn't it be the same when to plug in the usb?

  • But shouldn't it be the same when to plug in the usb?

    Please look at your dmesg output above, the bridge appears at the USB bus but then $something goes wrong. I've no Prolific USB-to-SATA bridges around and therefore also no experiences with them since AFAIK they still have none that is UAS capable (USB Attached SCSI) which is a basic requirement for me to keep CPU utilization low and performance up (though doesn't matter that much with HDDs anyway).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!