Can't reach WebGUI after update 3.x. SSH is working

  • Hello Everyone,

    First of all, a big appreciation and thanks to those who spend their free time to create and develop OMV!! :):)

    After the last update, I'm not able to reach the WebGUI and Nextcloud. But SSH is working. Therefore I checked the forum for similar problems and solutions, but I wasn't successful. I tried a few things.

    apt-get clean

    apt-get update

    apt-get upgarde

    service nginx status

    root@openmediavault:~# service nginx status
    ● nginx.service - LSB: starts the nginx web server
    Loaded: loaded (/etc/init.d/nginx)
    Active: active (exited) since Mo 2017-10-16 11:00:43 CEST; 3min 55s ago
    Process: 599 ExecStart=/etc/init.d/nginx start (code=exited, status=0/SUCCESS)

    And service openmediavault-engined status...which had a warning

    Did I destroy somehow the openmediavault-engine?

    Maybe this is also of help
    dpkg -l | grep openmediavault

    root@openmediavault:~# dpkg -l | grep openmediavault
    rc openmediavault 3.0.88 all Open network attached storage solution
    rc openmediavault-autoshutdown 3.1.4 all OpenMediaVault AutoShutdown Plugin
    rc openmediavault-backup 3.6 all backup plugin for OpenMediaVault.
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    rc openmediavault-letsencrypt 3.2 all Generate free and valid SSL certificates for OMV
    rc openmediavault-mysql 3.0.4 all MySQL plugin for OpenMediaVault.
    rc openmediavault-nginx 3.0.11 all Nginx plugin for OpenMediaVault.
    rc openmediavault-omvextrasorg 3.4.26 all Package Repositories for OpenMediaVault
    rc openmediavault-wakealarm 3.2 all wakealarm plugin for OpenMediaVault.

    I use OMV mainly as a Nextcloud platform and I would be grateful for some help.


  • Thank you for your answer. I ran several updates through the WebGUI, didn't choose all of them. One produced an error and I rebooted the machine. Afterward I got stuck with the problem. It is strange that the packages have been removed. Was not my intention at all!

    Has someone else an idea how I could fix it?

    I noticed to late, that I posted somehow in the wrong section. Sorry for that. Maybe a moderator could move it to general.

  • Hello Wolf2000. Thank you for your reply. I haven't tried apt-get purge. But the output of apt-get install reinstall openmediavault wasn't that successful I guess. Since I chose German as system language, line 2 to 5 are:

    • 2.Reading package lists... Done
    • 3.Building dependency tree
    • 4.Reading state information... Done
    • 5. E: Package reinstall couldn't be found.

    I am still confused why all packages have been removed. Are they removed every time an update is performed?

  • Thank you ryecoaaron. I ran the command and 152 packages were installed. In between an interface came up, where I had ti choose between two different FTP setups. I picked the upper one for rare FTP usage. Afterwards the following message was in between the installation:

    update-initramfs: Generating /boot/initrd.img-4.9.0-0.bpo.3-amd64
    W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
    W: mdadm: no arrays defined in configuration file.
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: warning: current start runlevel(s) (empty) of script `smartmontools' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (1 2 3 4 5) of script `smartmontools' overrides LSB defaults (1).

    If you would like to see the full output, pls let me know.
    According to the last interface the installation should be finished with omv-initsystem

    root@openmediavault:~# omv-initsystem
    W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
    W: mdadm: no arrays defined in configuration file.


  • After a restart I was able to reach the WebGUI with my password!! 8o But all my services/plugins are gone. All of them have the "rc" status. Autoshutdown, MySQL, etc. Is there a way to restore MySQL plugin? Should I reinstall the plugins as I did with OMV, with the hope, that all old configuration files will be available?

  • After fixing an DNS problem, I continued with the re-installation. Due to the help I was able to reinstall all plugins, which still had all my settings. There was no difference in SSH installation via apt-get install --reinstall openmediavault-XXXX (XXX - plugin name) or over WebGUI->Plugins. The MySQL plugin had to be disabled and enabled, before nextcloud was reachable.

    A big THANK YOU to macom, Wolf2000 and ryecoaaron. :)

  • I had a similar problem moving from 2.x to 4.x on logon.
    I executed the commands
    systemctl unmask openmediavault-engined
    systemctl enable openmediavault-engined
    systemctl restart openmediavault-engined

    I tried to install ntp and managed to remove chrony and OMV, after adding packages back I figured out this same solution.

    freaked out for a few minutes :-)

    Does anyone know how to end the log messages like:
    php: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.


    omv-engined[7781]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!