Medusa and docker problem

  • Hi everybody,


    today I wanted to give a try to Medusa, cause I find some limitations to SickRage that I use since few months.
    Unfortunatly I was unable to install it (via Docker https://hub.docker.com/r/lsioarmhf/medusa/ ).


    When I create the image with this command :


    Code
    docker create \
    --name=medusa \
    -v /opt/medusa:/config \
    -v /srv/dev-disk-by-id-ata-WDC_WD60EFRX-68L0BN1_WD-WX31DA5D65RF-part1/DOWNLOADS/MEDUSA:/downloads \
    -v /srv/dev-disk-by-id-ata-WDC_WD60EFRX-68L0BN1_WD-WX31DA5D65RF-part1/VIDEOTHEQUE/SERIES:/tv \
    -e PGID=1000 -e PUID=100 \
    -e TZ=Europe/London \
    -p 8082:8082 \
    lsioarmhf/medusa

    I get a "data container" witch is Stopped and that I cannot modify through the docker gui.



    Could someone help me through the installation process ? :)


    I'm running OMV 3.0.89

  • Seems like my problem isn't really popular ^^
    I tried to replace the "docker create" command by the "docker run" , I have a container running... but I'm unable to see anything through the 8082 ports.


    Is it ok that even when I configure those ports, I see in the Docker Gui my 8082 TCP ports AND a 8081 port configured ?

  • Here is my log :



    I don't understand how to make the /config directory writable.
    In my OMV shared folders I used ACL and checked :
    admin user/group
    root user/group


    Anything I am missing ?

  • okay first up


    hostport: 8082
    exposed port: 8081/tcp
    like this> https://i.imgur.com/zPYnavX.png




    then you need to set a directory for your TV-shows & a Downloads and Config like this:


    https://i.imgur.com/tMdGfJu.png


    notice that under the hostpath u need to put your own Directory four your "TV-Shows download directory" and where to put all the config files and also a download folder


    i suggest making a directory that named /docker-configs/medusa in root of your OMV drive, (with ssh) and keep set the configs for medusa for that directory (/docker-configs/medusa) thats the way i would have done it (you can do this through ssh) :-)



    edit: show me how your configures is in the container like i did :-)



    edit 2: if you need any further help, you can add me on discord "FilleDK#7643" (admin, remove this last line if its not allowed here) :-)

  • Thanks @filledk for your answer !


    First of all, I'd like to use side by side Sickrage AND Medusa (in order to test Medusa first).
    Am I wrong if I configure like this ?
    hostport: 8082
    exposed port: 8082/tcp >> because 8081 is used by SR.


    I allready made the directories you told me, and pointed it to the /config , /downloads, /tv


    Here is my config :



  • The PGID and PUID environment variables shouldn't be set to 0.
    Which user are you using to run dockers? I created a new user just for dockers and you can find out its PGID and PUID doing an ID "USERNAME" (SSH into your machine).
    Also why your folders are set to read only?

  • Ammiraglio
    no it shouldnt, its just to test if he can get it working...



    gulihem
    what you need to disable the R/O (Read Only) in the for the /config , /downloads, /tv and save that by clicking on> https://i.imgur.com/hbVTzCp.png


    if you cannot disable the R/O (Read Only) may actully have to create a new container with the same data to be able to to disable the R/O (but first try with editing it)


    Edit: u might have to use the "linuxserver/medusa" instead (thats what i used anyway and it worked


    Edit 2: the linuxserver/medusa (might) actully NOT work for a ARM processor,

  • Thanks for your replies :)


    I managed to make Medusa work... basically using the medusa github repository in the Sickbeard config.
    I did not manage to have a working docker container so I dropped this idea ^^


    Just for my knowledge : I tried to disable the R/O property on thoses folders.... but I failed ! How do I do that thing ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!