Unable to create shares - cannot select device

  • Hi folks,
    I have successfully managed to install OMV 3.0.89 on a WD MyCloud Gen2 6TB NAS device. It all went smoothly, however, I am running into problems when creating shares. That's what I do:


    - Click "Shared Folders" in the menu
    - Click "Add"
    - Try to select a device by clicking the little down arrow in the Device field


    => Nothing happens. I cannot select a device on which a shared folder could be generated. The Device field still says "Select a device..."


    My idea was to check the available devices in File Systems. Two partitions are listed:


    /dev/sda2,,ext4,5.41TiB,5.14TiB,57.94MiB,Yes,No,Online
    /dev/sda3,,ext4,2.68GiB,1.36GiB,1.1 GiB, Yes,Yes, Online


    Further, I tried unmounting the sda2 partition via GUI. When clicking the Unmount button, I get this error message:

    I have no problem mounting/unmounting the partition as root on the shell.


    That's how mount shows the devices:


    Quote

    /dev/sda3 on / type ext4 (rw,relatime,data=ordered)


    /dev/sda2 on /home type ext4 (rw,relatime,data=ordered)

    Here is the fstab output:


    Any help is appreciated!

  • Solved:
    - Partition Type needs to be 15 (Linux Filesystem)
    - Partition must NOT be mounted in /etc/fstab but rather in the GUI.

    Hi!


    I am having the same problems you had with my WD My Cloud Gen2. I followed the instructions of Fox to install Debian and OpenMediaVault, but I am having the exact problems that you described.


    I am not very used to work with partitions, and I don't know a lot about fstab and partition types. Could you tell me how do you solved it? How can I do those things?


    Thanking you in advance,
    Xoán

  • Problem - it is impossible to select the device on which we create the shared resource
    This is most likely due to the fact that on the laptop with which WD My Cloud is configured, Windows is installed.


    If you go over SSH to WD My Cloud and type the command fdisk -l, then you will see the source of the problem:

    Code
    Device Start End Sectors Size Type
    /dev/sda1 2048 1953791 1951744 953M Microsoft basic data
    /dev/sda2 7813120 488396799 480583680 229.2G Microsoft basic data
    /dev/sda3 1953792 7813119 5859328 2.8G Microsoft basic data


    The data partition type is 6-Microsoft basic data, and should be 15-Linux filesystem
    We do the following:


    that is, we changed the type of the data section and unmounted it.
    After that, already in the OMW Web interface, a data section was mounted and we had the opportunity to select it

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!