Windows 7 - no network share connection possible

  • have read the thread
    seen the video depending the cifs/smb part


    one question, i've seen i can connect local on the NAS to the samba share:
    this is what i get, can this help ?


    smbclient -L localhost
    WARNING: The "syslog" option is deprecated
    WARNING: The "syslog only" option is deprecated
    WARNING: The "null passwords" option is deprecated
    Enter barry's password:
    session setup failed: NT_STATUS_LOGON_FAILURE

  • Is samba running?


    systemctl status smbd


    Code
    root@omv3:~# systemctl status smbd
    ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
       Loaded: loaded (/etc/init.d/smbd)
       Active: active (running) since Fri 2017-06-23 14:06:47 MDT; 1 day 20h ago
      Process: 1007 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/smbd.service
               └─1048 /usr/sbin/smbd -D
    Notice: Active: active (running) since

    If you make it idiot proof, somebody will build a better idiot.

  • systemctl status smbd nmbd
    ● smbd.service - Samba SMB Daemon
    Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
    Active: active (running) since Sun 2017-10-22 18:27:36 CEST; 3min 5s ago
    Docs: man:smbd(8)
    man:samba(7)
    man:smb.conf(5)
    Main PID: 7720 (smbd)
    Status: "smbd: ready to serve connections..."
    Tasks: 3 (limit: 4915)
    CGroup: /system.slice/smbd.service
    ├─7720 /usr/sbin/smbd
    ├─7721 /usr/sbin/smbd
    └─7722 /usr/sbin/smbd



    Okt 22 18:29:40 j3455-itx smbd[9434]: [2017/10/22 18:29:40.858896, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Okt 22 18:29:40 j3455-itx smbd[9434]: WARNING: The "syslog only" option is deprecated
    Okt 22 18:29:40 j3455-itx smbd[9434]: [2017/10/22 18:29:40.859158, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Okt 22 18:29:40 j3455-itx smbd[9434]: WARNING: The "null passwords" option is deprecated
    Okt 22 18:29:40 j3455-itx smbd[9434]: [2017/10/22 18:29:40.861198, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Okt 22 18:29:40 j3455-itx smbd[9434]: WARNING: The "syslog" option is deprecated
    Okt 22 18:29:40 j3455-itx smbd[9434]: [2017/10/22 18:29:40.861294, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Okt 22 18:29:40 j3455-itx smbd[9434]: WARNING: The "syslog only" option is deprecated
    Okt 22 18:29:40 j3455-itx smbd[9434]: [2017/10/22 18:29:40.861552, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Okt 22 18:29:40 j3455-itx smbd[9434]: WARNING: The "null passwords" option is deprecated



    ● nmbd.service - Samba NMB Daemon
    Loaded: loaded (/lib/systemd/system/nmbd.service; enabled; vendor preset: enabled)
    Active: active (running) since Sun 2017-10-22 18:27:36 CEST; 3min 4s ago
    Docs: man:nmbd(8)
    man:samba(7)
    man:smb.conf(5)
    Main PID: 7787 (nmbd)
    Status: "nmbd: ready to serve connections..."
    Tasks: 1 (limit: 4915)
    CGroup: /system.slice/nmbd.service
    └─7787 /usr/sbin/nmbd



    Okt 22 18:27:36 j3455-itx systemd[1]: Starting Samba NMB Daemon...
    Okt 22 18:27:36 j3455-itx nmbd[7786]: [2017/10/22 18:27:36.605380, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Okt 22 18:27:36 j3455-itx nmbd[7786]: WARNING: The "syslog" option is deprecated
    Okt 22 18:27:36 j3455-itx systemd[1]: nmbd.service: Supervising process 7787 which is not our child. We'll most likely not notice when it exits.
    Okt 22 18:27:36 j3455-itx nmbd[7787]: [2017/10/22 18:27:36.608882, 0] ../lib/util/become_daemon.c:124(daemon_ready)
    Okt 22 18:27:36 j3455-itx nmbd[7787]: STATUS=daemon 'nmbd' finished starting up and ready to serve connections
    Okt 22 18:27:36 j3455-itx systemd[1]: Started Samba NMB Daemon.

  • Looks as if it is running. What version? Your output look different than mine.


    Code
    dpkg -l |grep samba
    ii  python-samba                      2:4.2.14+dfsg-0+deb8u8           amd64        Python bindings for Samba
    ii  samba                             2:4.2.14+dfsg-0+deb8u8           amd64        SMB/CIFS file, print, and login server for Unix
    ii  samba-common                      2:4.2.14+dfsg-0+deb8u8           all          common files used by both the Samba server and client
    ii  samba-common-bin                  2:4.2.14+dfsg-0+deb8u8           amd64        Samba common files used by both the server and the client
    ii  samba-dsdb-modules                2:4.2.14+dfsg-0+deb8u8           amd64        Samba Directory Services Database
    ii  samba-libs:amd64                  2:4.2.14+dfsg-0+deb8u8           amd64        Samba core libraries
    ii  samba-vfs-modules                 2:4.2.14+dfsg-0+deb8u8           amd64        Samba Virtual FileSystem plugins
    root@omv3:~#

    Nevermind I see your on 4.

    If you make it idiot proof, somebody will build a better idiot.

  • Code
    dpkg -l | grep samba
    ii python-samba 2:4.5.12+dfsg-2 amd64 Python bindings for Samba
    ii samba 2:4.5.12+dfsg-2 amd64 SMB/CIFS file, print, and login server for Unix
    ii samba-common 2:4.5.12+dfsg-2 all common files used by both the Samba server and client
    ii samba-common-bin 2:4.5.12+dfsg-2 amd64 Samba common files used by both the server and the client
    ii samba-dsdb-modules 2:4.5.12+dfsg-2 amd64 Samba Directory Services Database
    ii samba-libs:amd64 2:4.5.12+dfsg-2 amd64 Samba core libraries
    ii samba-vfs-modules 2:4.5.12+dfsg-2 amd64 Samba Virtual FileSystem plugins

    only newer versions

  • i use smbpassd -a and added the local NAS user (me) to the samba password store


    now i see the shared folder in windows, also


    smbclient -L localhost


    is working in the NAS and shows the share without the error NT_STATUS_LOGON_FAILURE.



    I assume that the installation for OMV4 make some trouble with samba.



    In the samba log on the NAS i see NT_STATUS_ACCESS_DENIED and windows


    say the same.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!