[SOLVED] Disks do not spin down automatically

  • Hi all,
    I am setting up my second OMV server.
    This time I am trying to set a spin-down time for all the data disks.


    My configuration is:
    - No RAID
    - One SSD drive for the operating system + 5 individual SATA drives.
    - Drives are 3x8TB WD RED (5400 rpm) + 1x2.0TB Seagate + 1x1.5TB Seagate
    - SMART is enabled on all the disks with the following parameters: Power Mode = STANDBY and Check Interval = 1800
    - No scheduled jobs


    So, for every disk, I have set in Storage -> Physical Disks -> Physical disk Properties:
    APM = 1 - Minimum power usage with standby (spindown)
    AAM = Disabled
    Spindown time = 60 minutes


    But the disks never spin down. They always stay on.


    I tried hddparm -C /dev/sdX and can confirm that the disks are ACTIVE/IDLE
    I even tried to manually spin down the disks but after few seconds they have turned on (an exception has been logged in the system log).


    I don't know if it related, but using iotop, I also noticed that every 10 seconds there are 2 tasks that come up:
    - rrdcached -l unix:/var/run/rrdcached.sock -j ~/ -B -w 900 -f 3600 -p /var/run/rrdcached.pid
    - jbd2/sda1-8


    Also in the system log there are some CRON jobs running. I haven't set any myself. Probably they are system CRON jobs.



    Any idea?

  • Hi @tkaiser,
    how can the all 5 data disk have activities?
    I just installed OMV with standard parameters.
    No tweaking yet.
    No access from clients, as there are no clients yet.
    Also, one of the disks is NOT even referenced. Only file system created, no shared folder created. So there could not be activities from outside OMV core accessing it.


    I will try iosnoop, but as a completely new installation there should be no IO access to data disks.


    What I am doing wrong?

  • Better ask iosnoop than people far away, having no access to your system and not the slightest idea how you configured stuff.

    Hi @tkasier,
    I have been trying to run iosnoop but I always get permission denied.
    Scripts downloaded from https://github.com/brendangregg/perf-tools.


    Run as root and as my local user with sudo, all these commands give me the same error: "Permission denied":
    iosnoop, ./iosnoop, sudo iosnoop, sudo ./iosnoop


    If I type sh iosnoop or sudo sh iosnoop or sudo sh ./iosnoop or sudo sh iosnoop, then I get
    ./iosnoop: 64: ./iosnoop: function: not found


    What I am missing?
    I could't find help on other forums.

  • What I am missing?

    If you did not cloned the repo then most probably just the executable bit? And trying to use sh instead of bash won't work. If you're where the iosnoop script is the following should fix the access bits and functionality:

    Code
    chmod 755 iosnoop
    sudo ./iosnoop


    BTW: A translation of major:minor numbers iosnoop will show to usual device names can be done with eg.


    Code
    for device in $(ls /sys/dev/block/) ; do (source /sys/dev/block/${device}/uevent ; echo -e "${DEVNAME}\t${device}"); done
  • Hi ,

    If you did not cloned the repo then most probably just the executable bit? And trying to use sh instead of bash won't work. If you're where the iosnoop script is the following should fix the access bits and functionality:

    thanks for your quick reply.
    I had already set iosnoop to 777 before launching it.
    -rwxrwxrwx 1 1000 100 9112 set 6 10:33 iosnoop


    But doesn't work. "Permission denied"
    Even ./iosnoop -h or sudo ./iosnoop -h gives "Permission denied"



    Also running the commands logged as root gives Permission denied.



    I am puzzled...


    P.S. The second script works and gave me the major:minor translation

  • Hi Community,
    I am writing again to get support on my problem.


    As in the first post, my data disks do not spin down. I have set all the relevant parameters, but simply they always stay active.


    I have tried to get support on this issue in this thread, but I have received an answer to use an external tool to discover what is writing to the disks.
    Unfortunately the tool does not run.


    Also, there is nothing writing to the disks as there is no read/write noise coming from the disks.
    And one of the disks is also not referenced, so nothing can write to it.


    So I am back to step 0 and need to get support.


    What can I do to solve my problem?


    thanks a lot.

  • Unfortunately the tool does not run.

    Well, it does run (in general) so no idea why you're not able to execute it (which is an indication for something wrong around the script/binary).


    Anyway, you could check smartctl manual page for the '-o' section and check with -s on/off whether this makes a difference (of course disabling SMART prior to that in OMV UI)

  • Hi,
    this is the result of smartctl --all on one of the disks (the one that is not referenced):


    Just to make sure I make it right:
    You are suggesting to disable SMART from the web interface for the device and
    then activate the smart from terminal using smartctl -s on /dev/sdX ?
    What do you mean with '-o' section? Do I have to set the '-o' flag too? on or off?


    thanks

  • You are suggesting to disable SMART from the web interface for the device and
    then activate the smart from terminal using smartctl -s on /dev/sdX ?

    No, I was suggesting to read the full -o section of the smartctl manual page to get an idea what happens wrt -s on/off:


    And maybe it would help others willing to help to get an idea about your setup. Eg. all disks behind a RAID controller in JBOD mode (actively preventing disk spindown) or stuff like that...

  • Hi,
    I have been reading the smartctl manual to understand what could possibly causing the non spin down of the hard drive.
    I disabled SMART in genral settings and disabled SMART for the single HD, but if I type smartctl --info I still get SMART support is: Enabled.
    I tried hard but I don't understand what I should be looking.


    I am not using RAID. I just use single disks mounted.


    Honestly I just wanted to install a NAS software, I am not an IO expert.
    I need help to debug my current the setup. What tests should I perform?
    Maybe a BIOS setting?



    thanks a lot.

    • Official Post

    I am not sure if it is correct or not, but I was reading some remarks that WD reds are not friends with hdparm. Hdparm is the program used to spin down the drives.
    An alternative would be to use hd-idle instead.
    https://withblue.ink/2016/07/1…-to-build-a-home-nas.html


    You can serarch the forum, there is an installation guide for hd-idle.

  • Hi all,
    I think that I solved the problem.
    macom: hdparm is perfectly compatible with WD.RED disks, at least on mine.


    The problem was related to the SMART check interval.
    As I explained in my first post, it was set to 1800 seconds while the spin down was set to 60 minutes.


    What is not documented is the fact that the SMART refresh interval resets the counter of the 60 minutes... even if there is no disk access so the condition is never met.


    Working settings:
    Spin down time = 60 minutes
    Refresh interval = 4000 seconds


    Hope this can help others.

  • Hello everybody,


    despite this thread being old, I hope to get some help as I'm facing a similar issue.

    I have a fresh install ovm 6 running within kvm. The Sata controller is passed through and not available to the host system, so this should actually make no difference to a non virtualized setup.

    I have:

    3 x 3 GB HDD (from three different vendors) running in a raid 5 config with btrfs.

    1 x 512 GB SSD

    There is absolutely no data so far and there are no shares setup (I intend to use SMB)


    Since the HDDs are only supposed to spin up once a week for my backup, I wanted to make sure that they spin down properly before I continued with any further setup.


    I set the Spindown time to 5 minutes in the GUI for all HDDs, and also set the Advanced power management option to 1 - minize power consumption (spindown). Also, (since suggested here) I set the S.M.A.R.T. check interval to 3700 and the power mode to idle which I thought should also avoid a wake-up in case of SLEEP and STANDBY.


    Using sudo hdparm -y /dev/sdx I can manually spin down every drive. When manually set to standby, it seems to persist (as of now) but the automatic spin down just won't work.


    As suggested above I tried to use iosnoop but tbh I don't know what the output means or how to differentiate between different drives.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!