[GUIDE] Sickbeard+SABnzbd+Couchpotato+Headphones+Others

  • sudo -u couchpotato /usr/bin/python /opt/couchpotato/CouchPotato.py --pid_file=/var/run/couchpotato/couchpotato.pid --data_dir=/home/couchpotato/.couchpotato


    That is the command you should use, I am running a new version of the plugin so had to go and find out what was in the old init script.
    If it does not error out you need to do Ctrl-C to exit the app as it will run in the foreground.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • i ran the command and i got the following. any ideas?


    root@openmediavault:~# sudo -u couchpotato /usr/bin/python /opt/couchpotato/Couc hPotato.py --pid_file=/var/run/couchpotato/couchpotato.pid --data_dir=/home/couc hpotato/.couchpotato
    Traceback (most recent call last):
    File "/opt/couchpotato/CouchPotato.py", line 133, in <module>
    l.run()
    File "/opt/couchpotato/CouchPotato.py", line 89, in run
    runCouchPotato(self.options, base_path, sys.argv[1:], data_dir = self.data_d ir, log_dir = self.log_dir, Env = Env)
    File "/opt/couchpotato/couchpotato/runner.py", line 140, in runCouchPotato
    db.open()
    File "/opt/couchpotato/libs/CodernityDB/database_super_thread_safe.py", line 4 3, in _inner
    res = f(*args, **kwargs)
    File "/opt/couchpotato/libs/CodernityDB/database_super_thread_safe.py", line 9 3, in open
    res = super(SuperThreadSafeDatabase, self).open(*args, **kwargs)
    File "/opt/couchpotato/libs/CodernityDB/database.py", line 571, in open
    index.open_index()
    File "/opt/couchpotato/libs/CodernityDB/tree_index.py", line 162, in open_inde x
    self._open_storage()
    File "/opt/couchpotato/libs/CodernityDB/tree_index.py", line 1923, in _open_st orage
    self.storage.open()
    File "/opt/couchpotato/libs/CodernityDB/storage.py", line 99, in open
    raise IOError("Storage doesn't exists!")
    IOError: Storage doesn't exists!

    OMV 5 - 64 bit
    Dell T430, 16gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • Quote (modified) for another user with the same issue.

    Code
    Please check the /home/couchpotato/.couchpotato folder. There is a database folder in there.
    You can shutdown CP and you can remove everything accept _indexes/00id.py and id_store, id_buck.
    Then start CP again and it should rebuild your database.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Quote (modified) for another user with the same issue.

    Code
    Please check the /home/couchpotato/.couchpotato folder. There is a database folder in there.
    You can shutdown CP and you can remove everything accept _indexes/00id.py and id_store, id_buck.
    Then start CP again and it should rebuild your database.


    i looked in the folder and i see this


    root@openmediavault:~# cd /home/couchpotato/.couchpotato
    root@openmediavault:/home/couchpotato/.couchpotato# ls
    cache custom_plugins database db_backup logs settings.conf

    OMV 5 - 64 bit
    Dell T430, 16gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • Go into the database folder and delete everything inside except the folder _indexes and the 2 files (id_store, id_buck) then go inside the folder _indexes and delete all apart from 00id.py


    Before deleting anything make sure you run
    /etc/init.d/couchpotato/ stop

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • thank you jhmiller that's works took ages having to type rm and all the different files lol sure there's a easier way but for me i didn't know how so did them all manually. but it now starts and loads :D

    OMV 5 - 64 bit
    Dell T430, 16gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • Better to use mc (midnight commander) apt-get install mc, then just mc to start (F10 to close)

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • I do not know if this has already been covered before. I do not think so but there are 48 pages.


    I found reference to someone wanting to use the autoProcessTv and the sabtosickbeard scripts. But there did not mention if it was supposed to be provided with the package. I checked the home/sickbeard folder and there is not an autoprocesstv folder.


    I just wanted to know if I was looking in the wrong place or if I have to download the build from sickbeards site and copy the folder/contents over.


    thanks.

  • Its in /opt/SABnzb/AutoProcessTV.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • awesome. thanks


    now I have an issue where I can not access the folder. I try to and it gives me errors.
    I would guess its a permission issue but do not know how to check that in openmediavault.


    so to better clarify. I was checking the interfaces access rights management section and it wont let me change permissions for directories like /opt



    ----------------
    ok I figured it out. I was trying to chmod but was trying to do it from an ftp client that had root access. BUT it didn't work. I had to remote in and change permissions.

  • Why would you get a permission denied error? The fiels are utilized by SABnzbd, so they have to be owned by sab, which they should be.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • ok now the issue is. In my config everything should have been good by default but unfortunatly when I try to access sickbeard from (ip):8081
    nothing loads but doesnt give page not found error. I can access from IP/sickbeard though.


    any ideas? general configuration page does show port 8081 in sickbeard.
    **added info**
    IP:8081/sickbeard does work though. Just noticed that.
    thanks.

  • It's only via port OR via /sickbeard. Can't have both. That is a checkmark setting.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hi all,


    First of all, thx for all the work done.


    However, I have 2 questions/requests:
    - Could it be possible to add the french fork of sickbeard (available here: git://github.com/sarakha63/Sick-Beard.git) in the list of possible installation ?


    - I have installed some apps yesterday (couchpotato, sabnzb, ...) each time I have answered YES to add a link in the side menu, but after the installation has completed and a reboot of the NAS, no link are available on this menu
    => Is it because I'm running Openmediavault v1.9 ?


    Regards

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!