"mdadm no arrays found in config file or automatically disable" msg after 3.x to 4.x update

  • Hi all,

    I really enjoy OMV and very happy with it! But I'm having some trouble after updating to OMV 4.x. I'm getting this message when booting "mdadm no ARRAYS FOUND in config file or automatically disable". The message is spamming the console trying to find a RAID array and slowing down the boot process, my drives aren't on RAID. Tried messing with grub and setting raid=noautodetect rd.md=0 as kernel paramenter and didn't work. If someone could help me with this problem.

    Thanks in advance,
    Best regards for the devs and community. ^^

  • Hi bugnotme,

    # definitions of existing MD arraysARRAY <ignore> devices=/dev/sda
    in the /etc/mdadm/mdadm.conf helps but i have not tested it till yet.

    *future backup system*
    OMV 3.0.96 (Erasmus) -
    Linux 4.9.0-0.bpo.4-amd64
    Core2Quad Q8200 @2,33 GHz | 6 GB
    Intel SSD 320 40GB System |
    6x2TB WD-Red Raid5

    *replacement under construction*
    OMV 3.0.96 (Erasmus) -
    Linux 4.9.0-0.bpo.4-amd64
    i3-2120 @ 3,30 GHz | 8 GB
    Sandisk SSD 126GB System | 3x6TB WD-Red Raid5

  • Hi, :)

    I tried ARRAY <ignore> devices=/dev/sda and it didn't work. Tried to put ARRAY <ignore> devices=/dev/sda1, 2 ,3.. sdb1 sdc1 sdd1....etc on each line and it still tries to search for a raid on boot. Tried the omv-mkconf mdadm command and it returns a warning saying mdadm /etc/mdadm/mdadm.conf defines no arrays.

    EDIT: uhm, I reboot and it seems that omv-mkconf mdadm did the trick! I forgot to say that I cloned the drive with the os to another drive using the clonezilla. I'm just getting this error now during boot [FAILED] Failed to start Check And Enable File System Quotas. See 'systemctl status quota.service' for details. I typed systemctl status quota.service and it returned

    ● quota.service - Initial Check File System Quotas
    Loaded: loaded (/lib/systemd/system/quota.service; enabled; vendor preset: enabled)
    Active: active (exited) since Sat 2017-11-04 15:37:45 -02; 7min ago
    Docs: man:quotacheck(8)
    Process: 310 ExecStart=/usr/share/quota/quota-initial-check.sh (code=exited, status=0/SUCCESS)
    Main PID: 310 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
    CGroup: /system.slice/quota.service

    But the system is still working.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!