How to safely recover from this mega failure ?

  • Hi,
    my OMV installation WAS 3.0.7x. It was not remotely answering from a couple of weeks and I could not phisically access it until this evening.
    It is a 2 parts hardware setup: one part is an HP316M1 with IBM1015 controller on it, the other part a case with 24 3,5" bays and HP sas expander, apower supply and a PCI module to power to the HP expander.
    Two raid groups were on it:
    14x3TB drives
    6x4TB drives
    RAID6 both !


    Switching the NAS on a smell of burned electronic raised from the HP316M1 and soon it switched off.
    From the 24 Bays case a continuos clicking was coming up from :( one or two drives.


    Ok, you are right, it is an horror story.


    Now I need to try to rebuild and recovery everything.


    I need some advice from the experts:


    Once I move the IBM card to another PC and connect it back to the 24Bays case, I need to discover what happened to the drives and eventually which have failed and recover sanity before trying to reinstall OMV. I need to do this in the safe possible way.


    Which tools do I need ? Which shell commands ? Which distribution/iso ?
    Any warning ? It is really an huge setup and I want to recover everything or as much as possible.
    Also I don't want any tool to start rebuilding the drives automatically but only if I manually start the process.


    Any help is highly appreciated !

  • Which tools do I need ? Which shell commands ? Which distribution/iso ?
    Any warning ? It is really an huge setup and I want to recover everything or as much as possible.
    Also I don't want any tool to start rebuilding the drives automatically but only if I manually start the process.

    this is a tough one. Is the OS drive still working? If you could move the OS drive, raid card, and drive shelf to a new server, it should boot fine. You would just need to run omv-firstaid to fix the networking.


    If you have raid 6 arrays, a drive or two shouldn't be a problem and there should be no need to start manually.


    If you don't want raid to start, you need to boot to single user mode or find a bootable linux distro that doesn't start mdadm on boot (I'm not sure which ones would do that).

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Update:


    I have moved the system drives and the IBM 1015 controller to another HP Gx machine. There was an ESXi Hypervisor installed. I have created a virtual machine and passed the system drives as RAW and the controller as passthrough device...
    ... everything was there, even the spare drive for each of the 2 RAID6.
    Openmediavault worked at first run after omv-firstaid network configuration.


    Thanks god !

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!