openmediavault-docker-gui apt error

  • I get this error (in german) for an:


    apt dist-upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Paketaktualisierung (Upgrade) wird berechnet... Fertig
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    1 nicht vollständig installiert oder entfernt.
    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n]
    openmediavault-docker-gui (4.0) wird eingerichtet ...
    sed: /etc/rc.local kann nicht gelesen werden: Datei oder Verzeichnis nicht gefunden
    dpkg: Fehler beim Bearbeiten des Paketes openmediavault-docker-gui (--configure):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
    Trigger für openmediavault (4.0.9-1) werden verarbeitet ...
    Restarting engine daemon ...
    Fehler traten auf beim Bearbeiten von:
    openmediavault-docker-gui
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  • fixed the problem for me, because the /etc/rc.local script don't exists before on my system

    While I admit that it should probably check that rc.local exists, it should exist on every OMV system. Strange that it doesn't exist on your system.

    omv 6.0.46-5 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.4 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • I use for installing a debian stretch netinstall iso.

    I guess that is something new. I think the rc.local code can be removed from the plugin anyway.

    omv 6.0.46-5 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.4 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • ryecoaaron
    yes, i have the same issue on fresh install of debian stretch netinstall iso + omv4.


    touch /etc/rc.local


    apt dist-upgrade


    and i saw:


    "Restarting engine daemon ...
    W: APT had planned for dpkg to do more than it reported back (0 vs 4).
    Affected packages: openmediavault-docker-gui:amd64"


    after the second apt dist-upgrade no errors

  • Fixed in 4.0.1 in the repo now.

    omv 6.0.46-5 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.4 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!