Unable to update OMV 3 or upgrade to OMV4

  • I've successfully upgraded OMV from 1.19 -> 2 -> 3.0.92.


    I was going to upgrade to 4, but received the following error when I ran omv-update as well as omv-release-upgrade:


    Ign http://packages.openmediavault.org arrakis/main Translation-en
    Fetched 133 kB in 5s (25.0 kB/s)
    Traceback (most recent call last):
    File "/usr/sbin/omv-mkaptidx", line 68, in <module>
    cache = apt.cache.Cache()
    File "/usr/lib/python3/dist-packages/apt/cache.py", line 107, in __init__
    self.open(progress)
    File "/usr/lib/python3/dist-packages/apt/cache.py", line 154, in open
    self._cache = apt_pkg.Cache(progress)
    SystemError: E:The value 'jessie' is invalid for APT::Default-Release as such a release is not available in the sources
    Reading package lists... Done
    Reading package lists... Done
    E: The value 'jessie' is invalid for APT::Default-Release as such a release is not available in the sources


    I've seen similar issues reported for earlier versions, but I didn't see anything for this error for OMV3/Jessie.


    Any pointers would be greatly appreciated.

  • What is the output of: grep -ir jessie /etc/apt/*

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • /etc/apt/apt.conf:APT::Default-Release "jessie";
    /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=jessie-backports
    /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=jessie-backports
    /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=jessie-backports
    /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=jessie-backports
    /etc/apt/sources.list.d/openmediavault-kernel-backports.list:deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
    grep: /etc/apt/trusted.gpg: Permission denied
    grep: /etc/apt/trusted.gpg~: Permission denied
    Binary file /etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg matches
    Binary file /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg matches
    Binary file /etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg matches

  • rm /etc/apt/apt.conf
    omv-mkconf apt
    apt-get update
    apt-get dist-upgrade

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!