Openvpn plugin on OVM4 ?

  • It has been modified to work on OMV4. I posted instructions for users that wanted to build and install it somewhere on here. I am not sure where they are though. If anyone wants to look through my post history (I don't have time to do so right now), you should be able to find it.

    Even though it was modified for OMV 4 and the latest code is in the repo, people are still having problems with it. And as technodadlife mentioned, the openvpn-as plugin hasn't been ported at all.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Even though it was modified for OMV 4 and the latest code is in the repo, people are still having problems with it. And as technodadlife mentioned, the openvpn-as plugin hasn't been ported at all.

    Oh, my bad. I missed that it was OpenVPN-AS you were discussing. As for the OpenVPN plugin, what issues are people having? I had to recreate all of my user configurations when I installed it, but aside from that, it's been running perfectly.

  • As for the OpenVPN plugin, what issues are people having?

    You would have to look at the posts. I don't help/read those threads because I don't know anything about the plugin.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Has any progress been made on the -as plugin?


    I've been bouncing my head off of dockers and plugins and command lines oh my!


    @TechnoDadLife - I followed your guide to setup transmission-openvpn, might it be conflicting with openvpn-as dockers? I think I've probably made it the farthest with the linuxserver image but seem to always run up against an impossible to fix permissions error...


    Code
    /var/run/s6/etc/cont-init.d/50-interface: line 11: /config/scripts/confdba: Permission denied


    and then


    Code
    ./run: line 3: /config/scripts/openvpnas: Permission denied

    There are forum threads about both but they seem to have died &/or never found a solution.


    Anyway, this is a far better means of checking in with the server than forwarding all the apps web UIs. Even over SSL it gives me a ... twitch. VPNing back home would make life a lot easier and safer. Thanks for the hard work team :)

  • Has any progress been made on the -as plugin?

    No and I doubt anyone is going to work on it. If you install the openvpn-as package, it has its own web interface and doesn't really need a plugin.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I used this Script from Angristan https://github.com/Angristan/OpenVPN-install
    It's pretty easy to use and straight forward if you can use the shell a bit :)
    It works fine for me, i created .ovpn files use openVPN on Android and the community App on Windows 10. Works great for now :)

    Hello,
    i'm new to OMV and allready getting addicted to it, thanks for a great work to all developers.


    Reference to oVPN script, i get below errors when creating users, something to do with home folders. What am I doing wrong?


    cp: cannot create regular file '/home/root/freelance.ovpn': No such file or directory
    ./openvpn-install.sh: line 939: /home/root/freelance.ovpn: No such file or directory


    Thanks!

  • I just reinstalled OMV 4.1.3 from scratch and when I enabled the OpenVPN plugin I got the following errors (in order):



    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf openvpn add '1bce585a-2513-432f-b132-c46735be1f00' 2>&1' with exit code '1': Easy-RSA error: EASYRSA_PKI does not exist (perhaps you need to run init-pki)? Expected to find the EASYRSA_PKI at: /etc/openvpn/pki Run easyrsa without commands for usage and command help.





  • I just reinstalled OMV 4.1.3 from scratch and when I enabled the OpenVPN plugin I got the following errors (in order):



    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf openvpn add '1bce585a-2513-432f-b132-c46735be1f00' 2>&1' with exit code '1': Easy-RSA error: EASYRSA_PKI does not exist (perhaps you need to run init-pki)? Expected to find the EASYRSA_PKI at: /etc/openvpn/pki Run easyrsa without commands for usage and command help.

    Can you specify is this a pc, mini pc, single board.
    Are you running as admin or logged as user.
    Steps to replicate this.


    Either way my advice it to remove plugin than open a terminal and uninstall openvpn service with apt-get remove openvpn

    And than install the plugin again, for me it looks like it probably failed to pull some dependency it needed and you got stuck in a weird error.

  • Are you running as admin or logged as user.
    Steps to replicate this.


    Either way my advice it to remove plugin than open a terminal and uninstall openvpn service with apt-get remove openvpn


    And than install the plugin again, for me it looks like it probably failed to pull some dependency it needed and you got stuck in a weird error.


    I'm running as admin on a HP Microserver Gen8.
    I actually managed to fix the issue by closing the error popup and by creating a certificate, at that point the error didn't show up anymore.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!