OMV 2.1 System Disk Died. How do I access folders in my Data Volume (Solved)

  • Hi

    I have an OMV system which had the OMV 2.1 System installed on an MSATA 32GB drive EXT4 File System.
    It has another volume with Data (Raid managed by Raid Card) on a Virtual Drive with XFS Partiion.
    The system has been running fine for about 2 years.

    Now suddenly the MSATA OMV System drive died completely and will not get detected in the BIOS.
    I installed a new MSATA drive and did a fresh install of the same version of OMV on this.

    The system is up, and I could see my Data Drive and was able to mount it. But I do not see the existing shared folders on it.
    I have checked through terminal as root that the folders are there on the Data Drive.
    I had just 2 users and just about 4 shared folders, and I don't mind creating them again.

    I just want to see the existing folders in the OMV GUI to assign users and permissions again and to be able to access my data.

    What will be the best way to accomplish this ?


  • I'd like to check a few things:

    You can't see the old drive even when you boot up with your new msata? That would be bad.
    You have a backup of /etc on your data-drive? If yes, you could check all neccessary settings within that backup.

    If both questions are answered with no, i suggest to step up to OMV3 und after reconfiguring install and use backup-plugin - once on data-drive and on isb-flash.


    Auch das geht vorbei ...

  • Hi

    A happy update.
    I could go into shared folders and browse and add all my existing folders on the Data Drive (Raid volume).
    I just created users and assigned folders and now I can access all my data.

    It's a good feeling that even after loosing the OMV OS MSATA Drive completely without a backup, I could easily access my data again.

    P.S. Admins, this thread can be marked as solved.


  • P.S. Admins, this thread can be marked as solved.

    You can do this by yourself.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Styler

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!