PlexPy working in OMV4.X?

  • I am running OMV 4.0.14-1 arrakis and PlexPy seems to be not running.


    I have enabled the installation and running options in the Plex plugin tab.


    But whenever I try to access the IP:port where the web service is supposed to be running (8182 as default) there is no service running as I get a 404 page.


    In 3.X erasmus it was working and I have a lot of notifications configured (telegram/mail) running like a charm.


    How could I chek if the service is running? I cannot find it under the Processes tab.


    Thanks in advance.


    PD: I tried


    Code
    systemctl enable plexpy


    But still not working

  • I tried the following:


    - Ensure that there is a plexpy.service in /lib/systemd/system path
    - systemctl daemon-reload
    - systemctl enable plexpy.service
    - systemctl start plexpy.service


    And I get the following error:


    PD: I manually created the user "plexpy" and now it does not give error at the moment of starting, but I still do not get any webUI.


    The process is working in the background:


    Code
    6695 plexpy 20 0 986760 43440 8096 S 0.0 0.1 0:00.51 python
  • I didn't add the plexpy stuff to the plugin and have no idea how to even test it. So, the code probably needs to be updated (or removed and put in its own plugin).

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Also changed back to docker for plex and plexpy in arrakis, but got plexpy working 100% before together with openmediavault-plexmediaserver:


    Install the plex plugin as usual, enable plexpy with port 8181. Then:


    First:

    Code
    sudo adduser --system --no-create-home plexpy
    sudo chown plexpy:nogroup -R /opt/plexpy


    Second:



    Code
    - systemctl enable plexpy
    - systemctl start plexpy

    HP Microserver Gen8 - 16GB RAM - 1x Kingston 120 GB SSD - 4x 3TB WD Red / ZFS - OMV 5.2.x bare metal - Docker running Plex, TimeMachine - Synology DS214 with 2x 4TB WD Red for rsync backup

  • Thanks, this does the trick :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!