Why php5 AND php7 packages in OMV-4 ?

  • Since upgrade from OMV-3 to OMV-4, i receive mails from monit or cron daemon each 30 mn :


    Code
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/pam.so' - /usr/lib/php5/20131226/pam.so: cannot open shared object file: No such file or directory in Unknown on line 0

    and here is error message from systemctl :



    Code
    openmv php5-fpm[1126]: [12-Dec-2017 21:38:04] NOTICE: PHP message: PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/pam.so' - /usr/lib/php5/20131226/pam.so: cannot open shared object failed to load dynamic library '/usr/lib/php5/20131226/pam.so' - /usr/lib/php5/20131226/pam.so: cannot open shared object file: No such file or directory in Unknown on line 0

    So i stopped Monit service and notification via Gui.


    Do i have to remove php5 packages ?

    - NAS 1 : Debian 10 (Buster) - OpenMediaVault 5.2.12-1 Usul - Kernel 5.8.0-0.bpo.2-amd64 - CPU Intel Pentium G3460
    - NAS 2 : Debian 10 (Buster) - OpenMediaVault 5.2.12-1 Usul - Kernel 5.7.0-0 bpo.2-amd64 - CPU Intel Core 2 Duo E8400

  • You potentially had an app using php5 packages so they couldn't be uninstalled. Try uninstalling. If they uninstall an app you want, then you will know.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Ok, so i try to remove plugins MySQL and Let's encrypt and have i new error :


    - NAS 1 : Debian 10 (Buster) - OpenMediaVault 5.2.12-1 Usul - Kernel 5.8.0-0.bpo.2-amd64 - CPU Intel Pentium G3460
    - NAS 2 : Debian 10 (Buster) - OpenMediaVault 5.2.12-1 Usul - Kernel 5.7.0-0 bpo.2-amd64 - CPU Intel Core 2 Duo E8400

  • Try (as root):


    mkdir /var/lib/mywebsql
    apt-get purge mywebsql

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Ok, thanks @ryecoaaron, to be able to see the new plugins for OMV 4, i had to install the dirmngr package before to run


    Code
    wget http://omv-extras.org/openmediavault-omvextrasorg_latest_all4.deb
    dpkg -i openmediavault-omvextrasorg_latest_all4.deb

    I have no more messages from Monit or cron about php error.

    - NAS 1 : Debian 10 (Buster) - OpenMediaVault 5.2.12-1 Usul - Kernel 5.8.0-0.bpo.2-amd64 - CPU Intel Pentium G3460
    - NAS 2 : Debian 10 (Buster) - OpenMediaVault 5.2.12-1 Usul - Kernel 5.7.0-0 bpo.2-amd64 - CPU Intel Core 2 Duo E8400

  • i had to install the dirmngr package before to run

    That is why the omv-extras install procedure always has apt-get -f install after the dpkg command. It will install the dependencies omv-extras needs and one of those is dirmngr.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!