SMB not working anymore freaking out over here

  • Today ever since i power up my NAS running OMV, i do not seem to be able to connect to my samba shares from anywhere. My laptop cannot connect, my android phones, nothing. I can connect via web ui to the static ip i have set, and it remains the same, i can connect to the ftp server and see the smb shares from there, but cannot for the life of me access the smb shares directly. I disabled and reenabled the smb service from omv, (applies each time of course) i've reset user accounts, prexeisting and even tried with brand new user credentials, powered off, and rebooted the machine, and for the life of me i cannot connect. I repeat, i can connect to the ftp and see samba from there and to webui from same ip, but access smb directly fails. Seriously wasted all my day trying to fix this and coming up short

  • Nothing in the samba log? Did you change anything prior to this issue occurring? Are your shares configured as browseable? (I assume you're trying to browse to the share). Have you tried using hostname and IP address to reach the share? (if IP works, you have a dns issue)

  • Shares are of course online, mounted and browseable. Which logs are you refering to. Besides NAS running omv my laptop is running windows. I previously could connect to shares by mapping them as network drives. Now i cannot do that. How do i reach the shares with the jsotname ip method? Im novice in that matter and dont have the nesecary experience. Please tell me which command i should run from either windows or linux console

  • There are logs for samba itself located at /var/log/samba/

    suppose the name of your server is "nas" and it has IP

    if DNS is working you could simply hit your windows key and type "\\nas" and hit enter to open the samba shares. If your dns is broken, you could type "\\" instead, and it should still work.

  • Well none work so...

    I can browse the shares via ftp and remote ssh with putty using my ip, but \\hostname and \\ip do not work

    What logs do you want my to paste here

    root@openmediavault3:/var/log/samba# ls
    cores  log.  log.desktop-lmkaumh  log.nmbd    log.smbd
    log.   log.          log.nmbd.1  log.smbd.1.gz
  • The logging of samba is off by default. https://forum.openmediavault.o…s-samba-Trouble-shooting/ shows how to enable them.

    Don't know what you changed in fstab but that would be the first thing to look at.

    There is a removable drive that checked for errors at startup and when it was not mounted it nagged me that drive was not fout and had a one and a half minute waiting period ooking to be found. So i removed that line entry from the stab so as not to check for it. But i feel this is harmless. It was an empty test drive, it did not have any files inside and of course no shares or anything at all

    I re-enter the line in fstab, added noauto so it does not automount to check it at bot, but i did not include some of the lines the other drives have like some weird entries that appear (user_xattr,noexec,usrjquota=aquota.user,gr....)

    Could this seriously be it? Why would samba service care that i removed this one line

    • Official Post

    What does systemctl status smbd show?

    • Official Post

    I don't think order is important.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!