Weird behaviour with docker on omv4 on orange pi pc2

  • So im runing 4.0.16-1 arrakis on a orange pi pc2 and its working perfectly, no idea if it matter at all but i installed omv3 with the specific image for this model then updated to 4 with omv-release-upgrade and everything went super fine, the system started without error, started samba, did some shares, the hdd works perfectly on a good speed given the device and hdd limitations etc but one i started to use docker i started with weird problems, about half of the dockers containers i try do not work, and i know i need to use either armhf or arm packages, as example Pihole works like a charm same with qbittorrent, both are setup the same, im even using the same macvlan i set up on the pihole guide, but when i tried several others the containers start and SEEM to work exept that i get connection refused on the assigned port, the containers even create the needed config files and folders in the assigned places but i cant see the ui no matter what i do, the must weird thing is that the chocho qbittorrent mentioned before works without any issue but this qbittorrent container DO NOT WORK no matter what i do or set up on the network part or even including those PUID and PGID values for the user i used to create the folders (i tried anything but again, the containers run perfectly and also they create their needed config files with or without the ID values), im totally lost here, can anyone help me here? my knowledge on docker and linux is heavily limited, any help is totally appreciated as i cant find any sonarr/radarr containers that work on this setup.

    TLDR: some docker containers give connection refused on the web UI while others work perfectly, even if the same app.

    PS: just installed nzbget and also seem to work perfectly atm

  • In fact these are my first steps on both omv and dockers, i wanted a cheap low power option to downloads overnight or even 24/7 for entire weeks on occassions, the nas part was an aftertought that seems to fit on the intended use...anyway, i started directly on omv 3.0 to 4.0 to be directly up to date, as you say this is a very small device but also its not so small to not be able to run some p2p and download apps and maybe some basic media center app like plex or something like that, im not using the device for anything else, its not in a desktop environment at all...and dont take me wrong, im not complaining at all, its free piece of software that works wonderfully on a weak device, when i install dockers on it i TOTALLY know that im pushing the limits allready, i just wanted some pointers to understand what can i be doing going to read your links and try again the containers im missing, up to this point i have runingin dockers: pihole, syncthing and nzbget up to date and qbittorrent very outdated but working but with some weird permissions problems not related to the OP...
    Again thanks for any and all tips/help

  • Link your thread in this post:

    Docker GUI plugin now stable

    Maybe one of the devs @nicjo814 or @subzero79 of the docker gui plugin can help you.

    Greetings Hoppel

    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8

  • My problem seem to be network related but i can totally try this:

    (Don't "pre-create" the folder on the host side - this would apply permissions from the default create mask. Allow the Docker container configuration to create the folder and assign permissions. On the other hand, given the restrictions imposed when working inside a Docker container, it might be best to map to an inside folder that already exists.)

    with the qbittorrent where i have problems changing the settings, they simply dont stay...(tho the weird thing is that the container DO create the default config file when first started if i delete it)

  • Had similar problems with several deluge versions then i decided to try with the good old transmission and this one: Transmission finally worked correctly without issues allways using the macvlan i created for pihole...with deluge i had the weirdest behavior ive seen so far, several containers guides strongly suggest to use host networking but i was unable to reach the daemon on host, on macvlan at least i was able to connect to the daemon but there where permission problems when the daemon was about to write on disk, allmost as if the daemon was runing as a different user...
    Anyway, updating just in case someone else try omv4 with docker on arm and need any of the same containers...thanks and i still cant find any radarr/sonarr container that work, any tip is greatly appreciated...

  • I'm afraid I don't have any arm boxes to play with so I can't test these images you are having issues with.

    However I might have some ideas on how to fix your issues...

    First try to run one of the "problem images" without mapping any volumes inside it. This should take care of any issues regarding permissions. If it starts and you can access it then you most likely had som permission issues.

    Next I would try to make sure that all other containers are stopped before testing (i you are low on resources).

    If it still doesn't work it might be a good idea to run "docker logs -f <name_of_the_container>" after having started a container to see if you can spot any errors.

    Finally make sure that the IP you are assigning the container is actually within the macvlan network you have defined.

  • As example this radarr container gives me some VERY nasty errors, im not very versed in linux language but smells like architecture problems (maybe?):

  • Similar (if not identical) messages repeat several times each time i start that one (both with and without mappings) and keeps apprearing more every few seconds...its a specific container for armhf so i shouldnt have architecture problems...also i have another 2 armhf containers from lsio so i can kinda trust their origin...

    "docker logs -f container" gives me

    Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.35/containers/radarr/logs?follow=1&stderr=1&stdout=1&tail=all: dial unix /var/run/docker.sock: connect: permission denied

    on all my containers (both the ones working fine and the ones that dont), maybe some weird harmless warning?

    Also the dashboard shows 35% memory used stable with the 5 containers that im using atm active at the same time, so i think that i can squeeze a pair more of lightweight ones like radarr and sonarr and the like, and cpu rarely goes over 30% too...

    The ip is correct as i have 5 other containers runing in the same macvlan and every one with a different ip and they all work perfect, i also did a ping when the container is on and i get under 1ms response, so the packets dont seem to be routed weirdly (the ping timeouts when the container is down so i know that its the container that opens that ip)

    Again, remember that i get a connection refused error on the browser and instantly (when the cointainer is up, ofc)

    Last, thanks flmaxey for the link, im reading it slowly as it is a bit complex for me, remember im simply a semi-advanced user, not a coder, im reading ir anyway to see if i can learn something to help with my problem...

    Thanks in advance for any help and sorry i wrote 2 posts in a row, had a problem with the 10000 char limit

  • I just did some extra research and maybe this is loosely related to my problem with radarr/sonarr? i got several other containers in different languages with similar problems tho...

    And now i see that the permissions denied error is because i didnt had access with that specific user, going to try again in a few mins...ok, dumb me, the logs button on the docker interface of omv gives me the same info as if i do manualy "docker logs -f container" on CLI (if i do it with a user with privileges)...

  • Yea yea after some more research i realized of my mistake and corrected it myself, read my edits on the previous post, basically gives me the same as the code box on my previous post

    One more edit, since uname tells me that this thing is runing in aarch64 i also tried an aarch64 version of radarr too...and JACKPOT!!! its runing, now i need to test if everything works but at least i get the web ui correctly...gonna search for some qbittorrent aarch64 to see if my problem there is related to that too...the weird thing is that in several places states that armhf code should work fine on aarch64 but again, im no coder or dev, im just trying different thing to see if they work...
    At least if this stays in the forum i can help a bit the poor folk that have similar problems on another opi pc2...
    Im going to keep testing things a few hours/days and post again more info or success rate as i keep setting this up...
    Again thanks in advance for any help :D

  • In fact i was searching by hand only writing the exact name of the application ("radarr" as example) without nothing extra but your idea is a bit more detailed because some containers dont show any architecture in plain but there is several options on the tags as in your pi-hole example...also in your pihole example i just downloaded the main "multiarch" package, im guessing that it auto-detect the system arch and probably there is where my problems started because i assumed that armhf where the better choice overall in my fact im going to move my packages to aarch64 now if i see no problems as it seem more specific for this hardware...

    And once again, very VERY helpfull and thank you :D

  • By the way i have a related question, how do we update the containers? im guessing that most package mechanism is locked inside a container so "apt-get upgrade" or any update mechanism proper to the app in question isnt going to work so i must use the "pull image" button and create a new container i guess? or the system is smart enough so if i pull a new image it also updates the related container without the need to create a new one?

    And some update, the qbittorrent problem was also related to architecture (even if it seemed like permissions problems) now i can write the config file, change my password, change any settings all with the aarch64 version, im so happy i found the solution to my problems... :D

  • OHHH now i see what do you mean!!! after all its so easy to download another image for a newer version of any app i might use and start a NEW container alongside the old one for a few days for testing im kinda new to dockers so sometimes i dont think of certain use cases as you can see and also i now know why most containers have the option to store the config files externally, to ease on updating!!! And no, im not worried about the bleeding edge, im happy to have most everything updated to 3-6 months old...(and not even because of new features but mostly because of security concerns)

    Also im planning to do a full raw backup of the sd card on the opi once i finish setting everything i want on it correctly...

  • Well yea, thats a bit to much for my use case, im conservative too and im considering starting from scratch but now knowing what to install exactly and how (ergo doing a whole totally CLEAN install) and then do the full backup when its ready but getting a second board just for testing feels a bit to much lol

    The full backup as i mention alleviate the problem of the merging images, in extreme cases i can roll back to the clean backup...your solution is perfect in fact, but the 2nd board ends in a drawer 99% of the time, feels like a waste, even if cheap...

  • Yea thats why i chose this one to be used as NAS, even if it have usb2.0 (giving me about 35-40MBs) its a lot better for a home use than any 100mbit wth board, and also 2 of the usb ports are HOST, no shared bandwidth with the eth either...ofc a better solution is an actual nas solution but this is so cheap that for home use is perfect...
    And i have 2 rpi3 here at home that the kids use to watch youtube and play some retro games, the opipc2 act as a server both for media as for the games lol
    Im also planning to buy an odroid xu4 in a not to distant future for the main tv, but thats another story, i love these small boards as you can see, and tinker with them too xD

  • So a last update about my situation, orange pi pc2 totally need aarch64 architecture dockers, EVERY docker i tested with a tag for aarch64 works perfectly, leaving this last comment here for any future opipc2 owner struggling with this ussue...
    The weird thing about this situation is that most armhf images i tested ran perfectly according to the docker ui, most dont even gave errors, but i was getting "connection refused" when i tried to connect to their web UIs instead of plainly not working...
    Cya and thanks for watching...

  • Since this is your thread:

    If you can, maybe you should insert orange pi pc2 and/or O-PI PC2 in the thread title. Also, it wouldn't hurt to add them as tags, along with the resolved tag. If someone comes looking, you might save them some grief.

    Just saw your tags and title suggestion and did the still having random problems and instability with dockers that include any form of MONO, apparently MONO is super unstable on aarch64 platforms, just so anyone else wanders in this topic with similar problems, probably they are gonna get fixed in the future when the h5 chipsets have better support...i think this is related but again im not not an expert so im not sure: mono arm64
    Going back to the first post some examples of mono based software that maybe someone will want to run on dockers: radarr, sonarr, jackett, emby.
    You can replace sonarr with sickbeard and maybe emby with some kodi-headless (since plex is not an option either)...
    Again thanks anyone for watching hopefully i save someone else with an opipc2 some time otherwise wasted searching and trying

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!