mdadm: no arrays found in config file or automatically

  • This worked perfectly for me. Many thanks.

  • Yes, thank you for giving us the "long" version. Many times on the forums people say "do this, or do that", but without the foundation behind it, it's not helpful. For myself, I have rarely, if ever toyed with or modified grub.

    A noob question though, how to issue the "blkid" command and get it to pause? I have 12 drives plus the boot drive on this system and the first items disappear off the screen pretty quickly.

  • I had this exact same issue on my HP N40L microserver after I upgraded the boot HDD to an SSD (240GB).
    I then partitioned the SDD (using gparted) and shrunk the boot partition to 20GB and created a data partition for the rest (minus a small Swap partition). So now I have 5 data HDD's plus one data partition on teh boot SSD.
    On boot I now have 36 "mdadm: no arrays found in config file or automatically" messages taking around 40 secs and eventually boots.
    The system is fine but those annoying messages delays the boot.
    Lot of googling resulted in no good reason as to WHY.

    In the end I "solved" (or got rid of those warnings) with the suggestion here.
    Edited /etc/mdadm/mdadm.conf and added:

    ARRAY <ignore> devices=/dev/sda
    ARRAY <ignore> devices=/dev/sdb
    ARRAY <ignore> devices=/dev/sdc
    ARRAY <ignore> devices=/dev/sdd
    ARRAY <ignore> devices=/dev/sde
    ARRAY <ignore> devices=/dev/sdf

    That is, one line of EACH drive.
    and the, ran update-initramfs -u command

    Now, after BIOS post, OMV boots in 30 secs.

    (BTW,Adding just one line for/dev/sda did nothing.)

  • It might sound crazy but i did something and it worked for me.

    Problem is caused by drives that changes paths after installation.

    Using the CD drive as installation medium seems to work for few people.

    What I did is, In Bios of my CPU, I have put the Sata Mode into IDE Mode instead of AHCI.

    Then the problem disappeared and everything worked just fine. :)

    Hope this helps.

  • Just adding _ I experienced the same thing just now installing 4.1.23-1 ( I am using a server that has limited SATA ports (everything is in a cage) and I wanted to use SSD drives for the OS outside of the cage). So I had to take the DVD drive stat port and use it for my SSD drive. Which in turn also forced me to use a USB thumbdrive to install the OS (from the OMV ISO) - OS installed fine, upon pulling the USB drive and rebooting - the server failed to boot giving the mdadm: no arrays found in config file - over and over again then dropping to initramfs prompt - there was also an error about /dev/sdj1 not exisiting.
    While in initramfs I ran blkid which listed my boot drive as /dev/sdi1 so I rebooted, entered grub and edited the grub file and changed /dev/sji1 to /dev/sdi1 and it booted fine.

    I use ZFS, so my next step after the clean boot was to change the kernel to a proxmox kernel any way, which I hoped should rewrite the Grub entries and possibly correct anything else. Added the proxmox kernel and rebooted again, worked fine - used the web interface to remove any other kernels and its running fine.

    Kinda weird - didnt seem to happen when I ran the Debain 9 installer and then manually added OMV - only happened when I used the OMV ISO.

  • I'm guessing the installer told grub to write to the wrong disk. Installing the proxmox kernel would update that info. There isn't a good way to fix this other than exposing the menu in the installer that lets you pick the disk grub is installed on. But that may expose too much.

    omv 6.0.42-2 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.23 | mergerfs 6.3.3 | zfs 6.0.11 plugins source code and issue tracker - github

    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Its really odd - cause now that everything is up and running, the proxmox kernel is the boot, in omv web interface disks - the boot disk is /dev/sda - not sdj or sdi.

  • Is there any plan to fix this? I cannot install OMV 3 because half way through install it says it cannot connect. I cannot install 4 because of this issue and I cannot use 5 because there are no Extras etc.

    Its really frustrating. I have aquired 4 new drives and wanted to put togther the final system config and cannot get anywhere. I tried FreeNAS which is soo complicated, I like OMV but I cannot use it!

  • For me, I think it was cleaner, easier and just worked out better to install Debian and then add OpenMediaVault. Things were getting squirrely when I used the OMV ISO and got worse when I tried to use the ISO from a thumb drive. If I recall correctly the issue was with drive labels switching around for some reason from /dev/sdi to dev/sdj - anyway I ended up just install Debian on the server, and got everything running how I wanted it (it was nice as well cause I could control the size of the boot partitions better than how it was getting calculated (I have large RAM, and was ending up with a very small boot partition).

  • Is there any plan to fix this?

    You would have to ask Volker.

    I cannot use 5 because there are no Extras etc.

    Really? Why do you assume this?

    omv 6.0.42-2 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.23 | mergerfs 6.3.3 | zfs 6.0.11 plugins source code and issue tracker - github

    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I thought I read somewhere that was the procedure? Nevertheless, glad ya got it going! So far I've been very happy with the move from freeBSD - and been very happy with the ZFS.

  • I'm really struggling with this and am exhausting having spent about a week of nights up until very late trying to get this to work. I'm coming from FreeNAS and wanted to switchover as I'm getting busier in life and was really attracted to having something on linux which was easier to maintain and could be potentially used for other things like home automation as well as being a better match for my lower tech capabilities and requirements. Unfortunately this single error has given me the complete opposite experience - I'm astounded to say that FreeNAS, although it took a bit of time to setup, was a breeze compared to what I'm going through now.

    I have a HP Microserver Gen8 with 2x 4TB drives (formerly in onboard RAID I think). I've just tried a whole bunch of things suggested on this thread including:

    • Setting controller from RAID > AHCI > IDE (Legacy)
    • Mounting the OMV and checking the mdadm.conf (did not exist in OMV5)
    • Modifying the grub after checking the blkids
    • Downgrading to OMV4
    • Installing on onboard SD card slot (along with a combination of the above)
    • Installing on SSD via CD drive bay (along with a combination of the above). This booted initially but then when I added the HDDs, it produced the mdadm error.

    No matter what I'm doing, I still get the mdadm error. I'm running out of options to try but next steps to try:

    • Checking if there's an mdadm.conf on OMV4 and modifying.
    • Reintroducing the working SSD and then adding the HDDs in. I have a suspicion that it has to do with changing mount names but have no idea how to fix it.
    • Several HP Server forum posts have suggested that I need to use the onboard RAID to create a separate RAID0 the boot SSD and keep the HDDs in the desired RAID config (I was previously 1) however doesn't this go against OMV convention of using software RAID?

    Happy to take suggestions but am also noting this down for others in case they can get some benefit from this.

  • Happy to take suggestions

    Well it's somewhat confusing, I have an N54L but I boot from a USB and have installed the bios hack which helps make life easier.

    I take it from reading the first section that the Gen8 has the capability to disable/switch off the Raid option from within the Bios, if so that is what you need to do.

    Have you backed up your data from your Freenas use? as you will need to start over. If you are watching the boot process via a monitor you will see the mdadm error, I do, if I have a monitor attached and I no longer use a Raid option.

    Will OMV boot and can you connect to the GUI via another computer without the 2x8TB drives connected.

    Raid is not a backup! Would you go skydiving without a parachute?

    OMV 6x amd64 running on an HP N54L Microserver

  • Sorry to hear your experiencing the issues, have to agree that FreeNAS (for me) also installed much smoother. I'm still liking the move, but I keep hearing (reading) rumors of OMV moving more toward BTRfs or some other set up (madam). Am kinda considering moving back FreeNAS as it is definitely ZFS based, iXsystems backed, pretty darn solid especially if ya don't upgrade much ;) - and trying better understand BSD. If each time I upgrade the server I just port the pool on to a new install, doubt I'll ever have much issues.

  • but I keep hearing (reading) rumors of OMV moving more toward BTRfs

    EVEN if OMV went btrfs only, I have said so many times (including that damn issue on github causing the problem) that there would be a plugin allowing other filesystems.

    some other set up (madam).

    Not sure what this means but omv already supports mdadm.

    iXsystems backed, pretty darn solid

    OMV is Debian which one would argue is pretty much the most solid distro out there. And being backed by Debian and for the most part Canonical (they support upstream), I think that is more than 100% of home users need.

    FreeBSD (and therefore FreeNAS) is moving to ZFS on Linux's code base if that tells you how supported ZoL is.

    omv 6.0.42-2 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.23 | mergerfs 6.3.3 | zfs 6.0.11 plugins source code and issue tracker - github

    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I'm not surprised you would need a BIOS hack. The HP BIOS is terrible, options are hidden in disparate sections and there is insufficient granularity for booting options.

    The drives have been backed up and I'm ready for them to be nuked if need be.

    OMV only boots up in one config: installed on SSD with no other drives connected. HP using AHCI controller. As soon as I try to load the HDDs, mdadm error.

    I just spent tonight testing out a variety of USB boot options (internal, external, SD card) and none of them worked - still mdadm error or unable to boot because I can't get HP to set the boot order specifically for connected devices to it just guesses (wrongly).

    Next step will be to remove the HDDs, bootup the SSD and play around with the mdadm config file. This will be the last chance saloon with OMV on HP microserver. I may consider dusting off an old HTPC with OMV and/or reverting back to FreeNAS provided it still works and the HDDs were unchanged.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!