Changing version of Plex between upgrading from OMV 2.x to 3.x

  • I am finally upgrading from OMV from 2.x to 3.x stable, via fresh installation. As part of this, I need to keep my Plex Media Server data directory. The problem is that the latest version in OMV 2.x is 1.9.4.4325, but the version in OMV 3 is 1.10.1.4602. Does anyone know if my data will work OK with the new version? Will it be upgraded, or does it not need to be?


    Alternatively, is there another repo that has an updated package for Debian 7? It would probably be best to update Plex to the latest version, then do the OMV 3 installation.


    Thanks

  • Hi, I yesterday upgrade OMV from 2.x to 3.x and then 4.x. I also use Plex Media sever.
    When upgrade has finished i must disable and enable Plex plugin, then it works fine.


    Tip: when upgrade finished 2.x 3.x the webui not loaded, just a white page (i think 500 error). Then i upgrade 4.x i got 502 on webui, so i run this: apt install -f


    This command solved my problem.

  • Those packages are valid for OMV 2.x. But they are not valid for OMV 3.x or 4.x. No point upgrading Plex if you are also going to upgrade OMV as Plex will be replaced anyway.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I wanted to upgrade Plex on OMV 2 before going to a newer version in OMV 3, just in case the new version didn't handle the migrated data directory well. I ended up manually upgrading to 1.10.1.4602 on OMV 2, and will be installing OMV 3 this week.


    Thank you all for the help

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!