Cannot login via any method

  • Hi all,
    I'm stuck.


    About a month ago (20th Dec 2017) I could ssh in on my username without issue, life was good.
    Now I am greeted in putty with "Could not chdir to home directory /home/<username-here>: No such file or directory"

    Code
    Could not chdir to home directory /home/dbe: No such file or directory


    I posted on here when I realized, and then forgot about it until I had time to try fix things. (What happened? No idea, I have not been installing anything new for months.)
    I am however, booting off USB, and we've had some power-outages due to severe weather.


    So here's where I'm stuck, I've forgotten the root password, and the web gui admin password is not working (don't think I changed it...)
    To reset the root password I've edited the recovery boot options in grub to drop me into /bin/bash, mounted the drive, set password, and then reboot caused a kernel panic.


    Thinking things are not going very well, I tried to login as root locally, it accepts the password but immediately loops back to the login screen, same thing from putty - immediate logout.
    Reading that an empty home dir is not a good omen, I connected the USB stick to an Ubuntu machine, and tried to fsck the partition, it comes up clean.
    I have 0 files or folders in /home.


    I rebooted OMV, took recovery mode in grub, entered the password to perform maintenance (JOY, it is accepted) and tried to run omv-firstaid. It fails to execute RPC, webgui password seems to remain unchanged.


    I'm currently stuck with a brick of a system that I have no idea how to recover.


    Worst case, will I be able to reconnect my raid drives if it turns out I need to re-install?



    Thanks for reading,
    dbell

  • Thanks @flmaxey,


    Unfortunately I was caught by my own laziness, kept meaning to clone the boot drive as a backup, never got to it.
    OMV had been working so nicely without intervention that I kept moving that lower on the priority list.


    As for rebuilding, is OMV 3 or 4 preferred at this point? It seems the life cycle on versions is fairly short for an open source offering of this nature.


    Also to clarify, you suggest leaving the SATA connectors attached to ensure the drives mount to the same names?


    Cheers,
    dbell

  • @flmaxey


    Sounds like you're saying 'use OMV 4', unless there was a typo somewhere in that paragraph. I don't see a positive argument for OMV3 in there. As for plugins I believe I was using a bare minimum, miniDLNA is the only one coming to mind.


    I certainly did have the flashmemory plugin enabled, however for the rebuild I had thought to use an SSD instead - though cloning then might be even less appealing. I'd appreciate your thoughts on this - force the install on a small partition and clone that?
    I don't suppose OMV has a 'settings backup' option in the GUI? It's not the installation I mind, it's that I need to go through the steps of reconfiguring something that had been working so nicely.



    I've used Win32Disk in the past as a way to create a bootable USB, I was not aware it would perform a clone as well, thanks for making me aware of that easy approach. For simple creation of bootable USBs I've now taken to using Etcher.io it's wonderfully simply for those who occasionally feel a little braindead.


    Also a huge thanks for the additional utilities tips, I made an img of the USB drive as it currently exists and I plan on trying out some detective work, so running h2testw sounds like a good place to start.



    Interestingly, I've run the installer for OMV3 (which I'll run again to go with your recommendation of OMV4) and after a clean install it seems the default behaviour is to keep /home folder in the / partition rather than separating it. There goes my suspicion that I'd lost simply lost the home partition.

  • I'm absolutely flummoxed.


    I was pretty sure that I'd narrowed down the login issue when I found that DEFAULT_HOME in in /etc/login.deps had to be "yes", I booted into recovery mode, went digging and found that it looked fine.


    So I let recovery mode finish the boot process...and now everything works. Why was it broken? I don't know! Why does it work now? Equally clueless.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!