first run script did not run?

  • I'm trying to install OMV 3 on a Raspberry Pi using the image OMV_3_0_88_RaspberryPi_2_3_4.9.41.img.xz. As far as I know, it is suposed to resize the system partition on the first run, and create a third partition for the rest of the sd card. However, my system partition is only 2.6GB on a 8GB sd card, and I don't see a third partition at all.

    What may be the problem, and how do I go about re-running the script that does this trick? I did try to re-enable the firstrun and resize2fs services, tried to start them, restarted the system with these enabled - but still no success.

  • Burn the image again on the SD card and follow the instruction on the download page.

    "REMAIN PATIENT PLEASE since this can take up to 30 minutes with a slow SD card and slowinternet connection (needs internet access to update all packages to latestversion)."

  • The same would've been the outcome. I figured out what happened in the first place.

    The image has a /root/.rootfs_resize file (I think - posting this from memory), with a requested FS size slightly larger than the sd card is. But the resize2fs script does not check this, and tries to fdisk it anyway, which thus rejects to save the new partiton table, and everything stays unchanged. Which is sad, since this way the space which IS available after the root partition remains inaccessible.

    The quick fix was to specify a smaller size in that file and re-run the script; thus the partition got resized, and also a (small) third partition created, which is useful to me (I can define a shared folder which is available even when the external hdd is not).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!