Keep getting wrong username/password when connecting to SMB /CIFS share

  • I have recently installed OMV 4 on my NAS. Network is a Windows Domain. The NAS is visible in the Network Tab on all PCs (Win10). So i created a user, shared folder / SMB share. The user has read/write permission to that share. But when I try to connect to the share (\\nas\share\) i keep getting an error saying username and / or password is wrong. I double checked already and it is correct.
    For troubleshooting I also set "min protocol = SMB2" as custom option but no success. Installing support for SMB1.0 on the Win10 machine also not make any difference. I really have no clue what is causing the error?!

  • Hi,
    I had the same problem on a couple of windows machines. Windows reset some parameters on a recent update.

    Try updating your windows network discovery options as shown in this video first.

    Build, Learn, Create.

    How to Videos for OMV

    Post any questions to the forum, so others can benefit from your curiosity. :thumbsup:
    No private support.

  • Well after some research I have found this thread: Samba not working on OMV 4.x while working on OMV3.x
    ntlm auth = yes allowed me to browse the shares and access them. But it seems to be not "best practice" regarding security. See here:…ntlm-for-windows-clients/

    After editing the security policy according to the information in the link abive and removal of "ntlm auth = yes" from the config, the same error occurs again and I cannot login. I made sure the policy has been applied to the computer. *clueless*

  • Today, same issue on 2 different equipments. Multimedia player and Win10 PC.

    As OMV4.1.4-1 is new for me, and after a few problems encountered since i upgrade omv3.0.99 to OMV4.0/4.1, now it is about multimedia players (2) at home.

    As all shares work before OMV4, i change some settings on my players, because i thought there have lost their settings... but not.

    i restart this nas, and always same issue.

    ssh/ ftp, all works, samba on win10 works now, but not my players in house.

    i 'm going to try ntlm auth = yes in optional section (samba) edit: it works with this parameter.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!