RTC Module on a RPI 2 with the OMV 3.x Debian Armbian (armhf) image

  • Link to old guide


    In the old RPi image the ntp server was not working after installing it. In the OMV 3.x Debian armhf image it does work. So the part in the old guide on the ntp server can be skipped. I just had to modify 3 files and install i2c-tools to get the RTC module recognized by the system. I will give the file edits now.


    /etc/modules

    Code
    mv_cesa
    r8152
    ax88179_178a
    i2c-bcm2708
    i2c-dev
    rtc-ds1307



    /boot/config.txt
    With this file all you have to do is add this line at the end of the file and save it:


    Code
    dtparam=i2c_arm=on



    /boot/cmdline.txt
    Add the following line to the end of this file and save it.

    Code
    bcm2708.vc_i2c_override=1


    After making those changes:
    apt-get install i2c-tools


    Then turn off your rpi, "shutdown -h now", and install your RTC module. See old guide via link above for more info. on correct pins if needed. If your rpi already has the RTC module installed you can reboot instead, "shutdown -r now".


    After reboot, or starting, your RPi should now recognize the RTC module. You can check with this command:
    i2cdetect -y 1

  • omv-mkgraph script failing. exiting script on check if service is disabled.


    /usr/sbin/omv-mkgraph


    Put # in check for service running and script ran:

    Code
    # Exit here if the rrdtool service is disabled.
    #[ "1" != "0" ] && exit 0



    The omv-mkgraph script is created by:
    /usr/share/openmediavault/mkconf/collectd


    Info. from this file that creates that line in the omv-mkgraph script:

    Code
    # Check if the system performance statistics service is enabled.
    enabled=$(omv_config_get "//system/monitoring/perfstats/enable")
    # Exit here if the rrdtool service is disabled.
    [ "1" != "${enabled}" ] && exit 0

    In the Web GUI under System/Monitoring the slider must be "Enable" or the omv-mkgraph script will exit early without creating graphs.
    Enabled the System/Monitoring slider and the omv-mkgraph script was rewritten. Graphs working normally now without editing the omv-mkgraph script.


    From the newly written omv-mkgraph script:

    Code
    # Exit here if the rrdtool service is disabled.
    [ "1" != "1" ] && exit 0

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!