No folders when connecting to FTP

  • Hello :)


    I'm not able to get folders when connectiong to FTP


    User with /bin/bash shell and read/write privileges (not ACL ^^) on the 3 folders I want
    I'm able to successfully connect to FTP with the user/password but I see an empty root


    I have configured FTP with this guide : ProFTP w/ Passive Ports setup Guide

    English isn't my native language, so, sorry if I made any mistake ^-^


    OMV 4.1.6 | 64 bit | openmediavault-omvextrasorg 4.1.6

  • Nope, they are added in the FTP section :-(


    My proftpd.conf file


    English isn't my native language, so, sorry if I made any mistake ^-^


    OMV 4.1.6 | 64 bit | openmediavault-omvextrasorg 4.1.6

  • Nope, they are added in the FTP section :-(


    My proftpd.conf file


    Non of those folders have privileges.

  • Code
    [{"passno": 2, "hidden": false, "fsname": "49182871-9c75-4a9b-8b23-b51ab41c5b54", "freq": 0, "type": "ext4", "opts": "defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl", "uuid": "5afa1785-5498-48c3-9d62-f837e8fec326", "dir": "/media/49182871-9c75-4a9b-8b23-b51ab41c5b54"}, {"passno": 2, "hidden": false, "fsname": "/dev/disk/by-label/GRAPPE8", "freq": 0, "type": "ext4", "opts": "defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl", "uuid": "6f7884e1-df31-47e4-85af-c5a8edf66523", "dir": "/srv/dev-disk-by-label-GRAPPE8"}, {"passno": 0, "hidden": true, "fsname": "5d7a7971-924d-4d40-8eff-1c61e0f27256", "freq": 0, "type": "fuse.mergerfs", "opts": "", "uuid": "facaef16-d32b-4cc4-8812-794f407143f9", "dir": "/srv/5d7a7971-924d-4d40-8eff-1c61e0f27256"}]
    Code
    [{"comment": "Fichiers infect\u00e9s", "name": "Antivirus", "reldirpath": "antivirus/quarantine/", "privileges": {"privilege": []}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "34199a64-fbb9-4840-8131-891566b03251"}, {"comment": "Nextcloud", "name": "Nextcloud", "reldirpath": "www/nextcloud/", "privileges": {"privilege": []}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "5b0072cb-9524-47f8-a0b3-c42411e14548"}, {"comment": "Racine", "name": "RACINE", "reldirpath": "/", "privileges": {"privilege": []}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "3fb980a5-1d13-405a-9cb0-cbf339e0fecd"}, {"comment": "Utilisateurs", "name": "Users", "reldirpath": "users/", "privileges": {"privilege": []}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "a5d850a7-958c-49a2-88cf-9d26f5d315d3"}, {"comment": "Backup", "name": "Backup", "reldirpath": "backup/", "privileges": {"privilege": []}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "db8455be-9bbd-4f39-bd59-e2bf14026d79"}, {"comment": "MyWebSQL", "name": "MyWebSQL", "reldirpath": "www/mywebsql/", "privileges": {"privilege": []}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "269ee581-a0db-4a1d-b637-debfbfaea104"}, {"comment": "", "name": "RACINE_8TO", "reldirpath": "/", "privileges": {"privilege": []}, "mntentref": "6f7884e1-df31-47e4-85af-c5a8edf66523", "uuid": "7d7eb9de-6049-46cd-82ea-6c9d9684cbe1"}, {"comment": "", "name": "RACINE_2TO", "reldirpath": "/", "privileges": {"privilege": []}, "mntentref": "5afa1785-5498-48c3-9d62-f837e8fec326", "uuid": "87666e87-264f-42c2-b397-30009eef3c18"}, {"comment": "", "name": "DL", "reldirpath": "common/Films/", "privileges": {"privilege": []}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "a4a78a5c-071a-48ae-9ae1-5628d7bc6e9e"}, {"comment": "", "name": "Crazy_Drink_Prod", "reldirpath": "www/crazydrink/production/", "privileges": {"privilege": [{"name": "crazydrink", "type": "user", "perms": 7}, {"name": "ftp-crazydrink", "perms": 7, "type": "user"}]}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "5b0f67f8-b9af-4936-a6ab-ea462f90c0a0"}, {"comment": "", "name": "Crazy_Drink_Beta", "reldirpath": "www/crazydrink/beta/", "privileges": {"privilege": [{"name": "crazydrink", "type": "user", "perms": 7}, {"name": "ftp-crazydrink", "perms": 7, "type": "user"}]}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "b214616f-c158-4661-b6b0-db0ecf343566"}, {"comment": "", "name": "Crazy_Drink_Blog", "reldirpath": "www/crazydrink/blog/", "privileges": {"privilege": [{"name": "crazydrink", "type": "user", "perms": 7}, {"name": "ftp-crazydrink", "perms": 7, "type": "user"}]}, "mntentref": "facaef16-d32b-4cc4-8812-794f407143f9", "uuid": "a33118a8-ff0d-4ddf-8ac9-d0af6c39d282"}]
    Code
    [{"comment": "", "uuid": "32d7f241-cd0f-4a78-8dda-ba8b685a48f2", "enable": true, "extraoptions": "", "sharedfolderref": "5b0f67f8-b9af-4936-a6ab-ea462f90c0a0"}, {"comment": "", "uuid": "c6082282-e65d-4d0d-9131-7e7492ee2dd2", "enable": true, "extraoptions": "", "sharedfolderref": "b214616f-c158-4661-b6b0-db0ecf343566"}, {"comment": "", "uuid": "29cfe17a-6751-4fa4-a23e-31b16ef21688", "enable": true, "extraoptions": "", "sharedfolderref": "a33118a8-ff0d-4ddf-8ac9-d0af6c39d282"}]

    English isn't my native language, so, sorry if I made any mistake ^-^


    OMV 4.1.6 | 64 bit | openmediavault-omvextrasorg 4.1.6

  • Everything seems correct, folder 'Crazy_Drink_Blog' ' Crazy_Drink_Beta' and 'Crazy_Drink_Prod' are with privileges assigned in the database, but not yet in the proftpd.conf file according to your previous post


    Please run


    omv-mkconf proftpd


    Then check in /etc/proftpd/proftpd.conf at least on of the usernames there

  • ftp-crazydrink was just a test and I have deleted this username since last time


    I have tried but the conf file is still the same :-/
    The file is modified because timestamp is updated after the command

    English isn't my native language, so, sorry if I made any mistake ^-^


    OMV 4.1.6 | 64 bit | openmediavault-omvextrasorg 4.1.6

  • Hi,


    I have the same problem. Probably a misconfiguration problem but cannot find where…
    Proftpd is configured with OMV GUI without any changes. I have tried with Filezilla and WinSCP, both fail. The connection seems to happen but no folder is visible.


    Here is my conf file.



    Any idea of what is going wrong ?

    Lian Li PC-V354 with Be Quiet fans | Gigabyte GA-G33M-DS2R | Intel E8400@3,6Ghz | 6GB DDR2 RAM
    1x500MB SSD for System/Caches/Logs/Backup/Downloads | 7x2To HDD RAID 6 for Datas
    Powered by OMV v4.1.29 / Kernel 4.18

  • Any idea of what is going wrong ?

    Try other user than root by using privileges. Haven't used root login, but if that ain't working it might be worth looking at proftpd documentation, there must be something to correct in the mkconf script when using root account.

  • Hi Subzero,


    I've tried with another user (and root), and still cannot get the folder list.



    Is there a default folder to set in Filezilla when the connection start ?



    I have set proftpd to be in passive mode and permit root login.
    It seems to be some kind of folder rights to me, but cannot resolve it.


    Cheers,

    Lian Li PC-V354 with Be Quiet fans | Gigabyte GA-G33M-DS2R | Intel E8400@3,6Ghz | 6GB DDR2 RAM
    1x500MB SSD for System/Caches/Logs/Backup/Downloads | 7x2To HDD RAID 6 for Datas
    Powered by OMV v4.1.29 / Kernel 4.18

  • Tried remote yesterday's afternoon, then local yesterday's evening.


    That's not a firewall problem as there is a connection, and I opened the port 21 on my internet box to make the tests.

    Lian Li PC-V354 with Be Quiet fans | Gigabyte GA-G33M-DS2R | Intel E8400@3,6Ghz | 6GB DDR2 RAM
    1x500MB SSD for System/Caches/Logs/Backup/Downloads | 7x2To HDD RAID 6 for Datas
    Powered by OMV v4.1.29 / Kernel 4.18

  • That's not a firewall problem as there is a connection, and I opened the port 21 on my internet box to make the tests.

    Passive range also needs to be forwarded also. Don't worry the server will open those ports on demand, but the firewall needs the rules there to allow incoming

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!