having a Issue with OMV 4.0 .

  • I am Using OMV 3x from 8 months and its Rock Solid, Simple Install, Stable Plugin and its worked fine, Its Awesome ...

    Today I saw a post in FB "At 30.06.2018 openmediavault 3.x will become EOL. This means no security/bugfix updates will be released anymore. Please upgrade to 4.x to be up-to-date" so i think that i should upgrade. so i tried to download that new version but when i click download its show me that the new version is 3.0.94. which already i have . but i figure it out and download the new version 4.1.3 . I just Export my ZFS Pool ....

    Lets Start the Installation. Create a USB Bootable Disk . Start Booting . got a first error "No Common CD/DVD Drive Detected" , Just Figure it out that boot from Ex-HDD that's why i got that error, so create a another bootable pen Drive. its working ... 8o I also try this command from shell ( mount -t vfat /dev/sdb1 /cdrom)

    Then there is a Configure the network Option (Where a need to select Primary network adapter cause my MB have a 2 Network Card) in 3X its show me like .. eth0: Intel , eth0: Intel but in 4x its show me like eno1: intel , rename3: intel , and it is not get auto config from my dhcp. so i configure manually and Complete the Installation ... ^^^^

    1st Boot
    After Grub menu its took 5 minute (cursor blinking in black screen) . wooo hooo i got the welcome screen ... :thumbsup:

    I found out that i have only 1 network interface . eno:1 (One is missing ). i restarted.

    2nd boot took same time.
    ipmi_si dmi-ipmi-si.0 interface detection failed .. I need Help here ..
    and i cant change my staic ip to DHCP . it wont let me save ..
    Do i need to run apt-get update and apt-get upgrade ...

  • try omv-firstaid to configure your NIC
    Connect both NIC to be detected

  • I tried Omv-First aid . i configure 1st interface "eno1" to dhcp . its worked . then i connect 2nd interface "rename3:" and configure to DHCP . it work too but it delete 1st interface configuration and from web ui its still showing 1 net work interface .. do i need to update my kernel to detect my interface . from omv-firstaid it showing both interface.

    I restarted .. it take same time and i got new error ..
    "a start job is running raise network interface "
    it take 2 mts ...

    Edited ---
    I ran apt update and apt upgrade .
    after update then reboot .

    my 1st "eno1" interface now named "rename2" and my 2nd interface "rename3" interface name "eno1:" . something is happening .. i dont know what to do ..

  • Thanks for Your Reply ..
    I tried to add but nothing there . so i delete my interface and tried to add and just found one .
    omv-firstaid showing both interface .

    configuring from Omv-firstaid, getting this error
    Error:Failed to execute command'export Path=/bin:/sbin:usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin;export lang=c; monitor collected 2>&1' eith exit code '1': cannot create socket to [localhost]:2812 -- connection refused

  • Just try to install Latest Version of Deian and I am getting same error in interface. Its Debian problem i think new version not working properly for me . :(

    Edit : Just installed with errors . (only one interface working) . then edit /etc/network/interfaces and add missing interface..
    auto rename3
    iface rename3 inet dhcp

    its worked but still can't find or ADD from GUI . :(

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!