Virtualbox plugin does not work after the upgrade from 3.0.99 to 4.1.6

  • Hi
    I just upgraded OMV to the latest. Everything almost went well. Except the virtualbox plugin.
    The plugin is not showing in the web interface
    It seems installed.
    root@home:~# dpkg -l |grep openm
    ii openmediavault 4.1.6 all openmediavault - The open network attached storage solution
    ii openmediavault-backup 3.11 all backup plugin for OpenMediaVault.
    ii openmediavault-cups 3.1.2 all OpenMediaVault CUPS (network printer server) plugin.
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-letsencrypt 3.4.5 all Generate free and valid SSL certificates for OMV
    ii openmediavault-omvextrasorg 3.4.30 all OMV-Extras.org Package Repositories for OpenMediaVault
    rc openmediavault-virtualbox 3.0.8 all VirtualBox plugin for OpenMediaVault.
    Trying to install from web interface results to this
    >>> *************** Error ***************
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install



    2>&1' with exit code '100': Reading package lists...



    Building dependency tree...



    Reading state information...



    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:



    The following packages have unmet dependencies:
    openmediavault-virtualbox : Depends: linux-headers-686-pae but it is not installable or
    linux-headers-amd64 but it is not going to be installed
    Depends: phpvirtualbox but it is not going to be installed
    Depends: virtualbox but it is not going to be installed
    Depends: virtualbox-ext-pack but it is not going to be installed or
    virtualbox-ext-pack-installer but it is not going to be installed
    E
    :
    Unable to correct problems, you have held broken packages.



    <<< *************************************


    I am little bit lost here..
    Any ideas?

  • The backport headers aren't pinned. apt-get install -t stretch-backports linux-headers-amd64

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I did it.
    same situation

    I cannot uninstall it neither...

  • You still have the old version of omv-extras installed as well. You need to upgrade that.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ok. We are getting there :)



    strange...

  • Code
    root@home:~# dpkg -l |grep openm
    ii openmediavault 4.1.6 all openmediavault - The open network attached storage solution
    ii openmediavault-backup 3.11 all backup plugin for OpenMediaVault.
    ii openmediavault-cups 3.1.2 all OpenMediaVault CUPS (network printer server) plugin.
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-letsencrypt 3.4.5 all Generate free and valid SSL certificates for OMV
    ii openmediavault-omvextrasorg 4.0.2 all OMV-Extras.org Package Repositories for OpenMediaVault
    ii openmediavault-virtualbox 4.1 all VirtualBox plugin for OpenMediaVault.

    but...
    I get this error in UI "Cannot use SplFileObject with directories"


    phpvirtualbox does not seem to work
    I cannot see the VMs nor start/stop them..

  • something is really wrong and I do not have a clue what..

  • Although I followed the link you sent before I tried it once more and it worked!
    I added couple of thinfg just to be on the safe side :)

    Code
    apt-get purge openmediavault-virtualbox phpvirtualbox virtualbox virtualbox-dkms virtualbox-ext-pack-installer
    rm -f /etc/default/openmediavault-virtualbox /etc/default/virtualbox
    rm -rf /usr/lib/virtualbox/
    userdel vbox
    groupdel vboxusers

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!