OMV4 DHCP DNS problem

  • Good evening,

    I have a problem when I want to overwrite my dns settings in omv.
    In my main NAS there are two partitions on my boot drive, so I had to put debian 9.4 up and install omv4 on it. (docker directory is on the second partition)
    When I go to omv's network card options, I wrote down 3 DNS server IP's, but after restarting the networking service or rebooting the NAS I see only my ISP's two DNS and the first one that I typed in.

    I tried it on another old machine with 1 hdd, installed omv from dvd iso, and it can override all three DNS's in resolve.conf. I assume this is the expected result.

    My ISP DNS doesn't let to resolve the ip-s, and lots of my docker containers fails, even with so simple things like apt-get update.

    PS: Even if I hack the dns with dhcpclient.conf on my main NAS, the docker container still not find the hosts... This trick has been worked on temporary machine and containers working flawless, so there should be another difference between the two installation.
    Maybe some kind of firewall settings in the debian?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!