Trouble Installing Some Plugins - Missing Core Packages - Missing Repo?

  • I am getting odd errors installing some plugins like shell in a box and nut:


    openmediavault-shellinabox : Depends: shellinabox (>= 2.18) but it is not installable


    And for nut, if I try and install the nut dependency that openmediavault-nut requires and complains about:


    sudo apt-get install nut
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package nut is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source


    It feels like I don't have all the sources or something

  • There is an issue with python version 2.7.13. So patching it with this fixed my apt-get update issue:


    https://github.com/python/cpython/commit/9cd7e17640a49635d1c1f8c2989578a8fc2c1de6


    If you get an error similar to this:


    Code
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fb2b905e2f0>
    Traceback (most recent call last):
    File "/usr/local/fbcode/gcc-4.9-glibc-2.20-fb/lib/python3.6/weakref.py", line 112, in remove
    TypeError: 'NoneType' object is not callable

    Then I was able to install core packages from base repos....

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!