Updated Version of Plugin Core Components

  • If a plugin - Nginx, in this specific example - has components that have been updated, but are not being used in the current version, is it possible to update those components directly without breaking the plugin? The Nginx plugin for OMV uses Nginx 1.6.2, but Nginx is now up to version 1.14.0. Can I update Nginx, or will that break the plugin?


    Does the answer to this specific example extend to other plugins and their respective components, or will it depend on the plugin and the components?

  • Can I update Nginx, or will that break the plugin?


    Does the answer to this specific example extend to other plugins and their respective components, or will it depend on the plugin and the components?

    Lets look at it a different way... The plugins are testing with the version of the component in the specific Debian repo for the version of OMV. The only way you can get a newer version of that component is to add a repo for a different version or build it yourself. Neither of those are supported by Debian or OMV because it would be impossible to test everything.


    If you want a newer version of a component, use a docker.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!