RAID5 not mounted after upgrade

  • Hi there,
    I just upgraded my OMV version 3.x (latest) to version 4.x
    After the final reboot the RAID5 array (md127) does not get mounted.
    /etc/fstab contains:
    /dev/disk/by-label/fs1 /srv/dev-disk-by-label-fs1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2

    But there is no directory "/dev/disk/by-label"

    I can see my RAID5 array in "/dev/disk/by-id/md-uuid-1f0917e1:8db686f6:f532b32f:76597ae5"

    mkdir /banane
    mount -r /dev/disk/by-id/md-uuid-1f0917e1\:8db686f6\:f532b32f\:76597ae5 /banane/ -t ext4

    The filesystem is mounted and all data is visible.
    (I unmounted if afterwards)

    How can I get "/dev/disk/by-label" populated ?
    How can I get OMV to use "/dev/disk/by-id/xxx" ?



  • Let me answer this myself.

    blkid did not list the md raid, but lsblk did.
    blkid -p /dev/md127 gave a hint:
    /dev/md127: ambivalent result (probably more filesystems on the device, use wipefs(8) to see more details)

    man wipefs ...

    wipefs -n /dev/md127 gave
    offset type
    0x82fcbbefc00 zfs_member [filesystem]
    LABEL: pool1
    UUID: 17414797601597129307

    0x438 ext4 [filesystem]
    LABEL: data1
    UUID: 870cef82-b75f-4c78-a111-213389d87c3f
    I can remember having fooled around with zfs and some BSD based system before going for openmediavault.

    wipefs -b -o 0x82fcbbefc00 -t noext4 /dev/md127
    said it had removed the zfs signature, but it didn't

    searching for known bugs in wipefs ...
    install buid-essential, download and unpack /util-linux-2.32, ./configure and make wipefs

    the new compiled version of wipefs revealed:

    md127 0x438 ext4 870cef82-b75f-4c78-a111-213389d87c3f data1
    md127 0x82fcbbef000 zfs_member 17414797601597129307 pool1
    wow, 15 zfs signatures (b*tch)
    md127 0x82fcbbe0c00 zfs_member 17414797601597129307 pool1

    After 15 runs of wipefs with the listed offsets there was just the ext4 and no more zfs signature.
    blkid now lists the md array and the filesystem is now visible in openmediavault

    This might be helpfull for others where the filesystem is not shown by blkid and hence not in openmediavault.


  • Wow...this was exactly the issue I had, except I have RAID6.

    Messed around with ZFS at the beginning before settling on OMV (about 5 years ago).

    I did not have to build wipefs...just repeat wipefs it several times and decrementing the offset.

    As a reminder to anyone else: always make sure you understand the commands you are executing before you blindly copy-paste commands from the internet.

    Thanks again Thomas! I owe you a beer!

  • Hey Thomas,
    you are my Hero! After the upgrade from OMV3 -> OMV4 my raid 5 did not work anymore. :evil:
    I have the same Problem! I think i have 25 -30 zfs signatures deletet !! ;(
    After this procedure my filesystem work! :D

    Thanks :thumbsup:

  • ananas:

    I wish I saw this earlier. After OMV 3.x to 4.x upgrade my RAID6 didnt show up in filesystem. I reinstalled 4.x from scratch and couldnt mount my RAID6.

    My previous 3.x install worked fine but stopped wanting to upgrade. So I manually did an apt-get upgrade which got me to 4.x but it still was acting weird. Raid6 not there.

    Fresh install same issue.
    What fixed it was doing :

    wipefs -n /dev/md127

    then every time it came back with a zfs signature, delete:
    wipefs -b -o <signature> -t noext4 /dev/md127

    Did that about 10 times until it came back clean. Then it was immediately seen in "Filesystems" and I was able to mount.

    THANK YOU THOMAS!!! A+++++++

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!