Docker and Plex - "There Are No Items In This Library"

  • I was running OMV 2.X with the OS running on a 120GB SSD and two 1TB spinning disks for data.


    I installed OMV 4 on the SSD, fresh install. Mounted the two disks and set up SSH, working great. My Mac is using Apple Filing and Time Machine to back up to one of the drives, working better than ever (it's faster now than it was on OMV 2.X for some reason).


    I installed the Docker plugin following this guide (following it more than once to ensure I've done it correctly) and it works almost perfectly. The problem is that Plex can't "see" the media on my data drive- I can "Browse For Media Folder" as far as I've set the Host Paths, but it can't/won't read the actual media.


    I've set up a .config file, and I've tried both directly entering the Host Paths and using this method- same results.


    I can only assume it's a permissions issue. Yet, I tried setting up a new directory with the following permissions:


    Code
    drwxrwsr-x 7 dockeruser users 4096 Jul 18 15:26 plexmedia



    And here is a sample directory inside:



    Code
    drwxr-sr-x 4 dockeruser users 4096 Jul 18 09:31 movies


    And so on...


    dockeruser is definitely a member of users.
    I'm definitely entering the correct PUID and PGID in the container.
    I'm definitely setting the correct paths.


    Can anyone explain why I might not be able to access these folders from Plex?


    I COULD give up, move the media and wipe the drive, but I'd like to solve this mystery (I am brand new to Docker).

  • What are the ownership and permissions of the files inside the directories?


    I set my Plex media directories and media files to be owned by user:fred group:users
    The container runs with PGID: 100 (users) PUID: 1001 (fred)


    Directories have permissions: 2755
    Files have permissions: 0644

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Hello gderf, my setup appears to be identical. I used chmod -R 2755, chown -R dockeruser and chgrp -R users to make sure all the files and directories were the same inside the main directory.


    One thing that surprised me is instead of the data drives being mounted at /dev/<UUID>, they are now at /srv/dev-disk-by-label-<diskname>. Not that it should matter.


    The owner and group or /srv and /dev-disk-by-label-<diskname> are root, which is normal as far as I can tell. My plex folder lives at /srv/dev-disk-by-label-<diskname>/plexfolder, and that has dockeruser as the owner and users as the group.


    My files are actually more permissive, they are all 755.

  • When I set up plex using docker on my machine I followed this guy in setting it up.



    I wasn't able to update, but using the information gleaned from the video, I was able to determine that the latest update to Docker which happened about a week ago, according to what I saw anyway, was that Plex now has it's own version of Plex Docker.


    Here is what I did:
    1. In a Shell sudo apt-get update && sudo apt-get upgrade (may or may not need the second sudo can't remember as it is 1:20 am and I just got it working again. This should update everything. Reboot)
    2. Go in to the Docker section and in the search area, just type "Plex", the first one to come up is going to be the official "Plex Docker", this is the one you want, not the linux/plex. "Start" it.
    3. Follow the video instructions through out the setup process in the video until he gets to "/media" instead of "/media" put in "/data", it will not work if you use "/media".


    Unfortunately you will have to put all of your folders back in like it is a brand new Plex Server, but it will work.
    Right now, I have all of my videos and music, being put in the "Library", I'm using 2 of my 4TB, so it's going to be tomorrow before its ready.



    Hope this helps


    Eric


  • If you are convinced that the ownership and permissions are correct, then your container must be malconfigured. Post screenshots of it.


    Also, it's not a good idea to set the executable bit on media files.


    The mountpoint for drives was changed from /media to /srv late in OMV 3's life, and carried over to OMV 4.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • gunneric: thanks for the tip! I'll have time next week to try to fix the server so i'll check out that new image with your other tips.


    gderf: good point re my permissions, I'll fix that up. interesting regarding the change from /media to /srv. I'll post some screenshots next week when I have time to work on my server.

  • There are no significant functional differences between the plexinc/pms-docker and linuxserver/plex dockers.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Here is where my .config folder lies:

    Code
    /home/dockeruser/.config/plex



    The permissions:


    Code
    drwxr-xr-x 3 dockeruser users 4096 Jul 21 16:31 .config


    My media folder:

    Code
    /srv/dev-disk-by-label-1TBUNIT2/plexmedia


    I currently have the directories and files owned by root



    Code
    drwxr-xr-x 19 root root 4096 Jul 21 16:50 family_movies
    drwxr-xr-x 76 root root 12288 Jul 21 17:42 movies
    drwxr-xr-x 347 root root 20480 Jul 21 17:57 music
    drwxr-xr-x 9 root root 4096 Jul 21 18:02 tv


    The files inside are also owned by root with 644 permissions.



    Here are some pics of my container configuration:


    pic1.pngpic2.pngpic3.png


    This is using the linuxserver/plex image


    Thanks for taking a look guys

  • I figured out what happened.


    When I set up the storage container as suggested by flvinny521, I didn't manually set the container paths. I assumed docker would get direct access to the host path.


    Well, that's wrong. The host paths are mounted inside the docker and get a new path. I manually set my container paths, navigated to them in Plex and all is well!


    Thanks for the help everyone.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!