Lost RAID 10 after Upgrading to OMV 4

  • Since upgraded from OMV 3 to OMV 4 two weeks ago, I ran into all kinds of trouble with my RAID 10 (Mediasonic ProBox 4 Bays via USB to Odroid XU4). The exact same set up ran very stable on OMV 3. Now on OMV 4, RAID failed to activate after reboot. After rebuilding RAID 10, it shows a degraded array (due to “sda removed”). I thought that was the problem and put in a new replacement drive for sda and let sync finish. But, after rebooting OMV 4, lost RAID again for the third time.

    It seems like RAID thinks all 4 drives as spare (S):
    # cat /proc/mdstat
    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
    md0 : inactive sdd[3](S) sdc[2](S) sdb[1](S) sda[4](S)
    15627550048 blocks super 1.2

    So, I stopped the mdadm and tried to start again, but my attempt to activate it failed saying that I only have 2 drives (I am pretty sure all 4 drives works and the RAID was running as clean right before the reboot):
    # mdadm --assemble --scan
    mdadm: /dev/md/Red assembled from 2 drives - not enough to start the array.

    I am running out of idea to reactivate the RAID again (after a few different approaches based on suggestions on different forums). Wondered if any suggestions folks here can offer.

    Thanks in advance!


  • Wondered if any suggestions folks here can offer.

    My suggestion that I have recommended many times is to not use raid on an arm board and to not use raid on usb drives. I think it was just luck that OMV 3 was stable since OMV 3 and OMV 4 both use the same kernel on an xu4.

    But if you insist on using it, this will be my only suggestion... I would try the following after stopping the array:
    mdadm --assemble --force --verbose /dev/md0 /dev/sd[dcba]

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thanks for this. I put it to Scheduled Jobs (on boot) and works several times of reboot. Meanwhile, I will consider a different hardware RAID storage solutions. Thanks again!


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!