OMV 3.x to 4.x issue

  • Hi,

    I wanted to make the upgrade from OMV 3.x to 4.x.

    I first checked that my plugins were compatible with OM 4.x then upgraded.

    See attached a screenshot of the end of the operation.

    I saw the Python issue, and try to fix it by editing the followin lines:
    - line 109: defremove(wr, selfref=ref(self)): replace with:def remove(wr, selfref=ref(self), _atomic_removal=_remove_dead_weakref):
    - line 117:_remove_dead_weakref(d, wr.key) replace with:_atomic_removal(d, wr.key)

    I was trying to find some clues after that, but I had to shut down the server for a while (eletrical maintenance in the neighborhood).
    Anywway, after powering it back on, I can see that:
    - transmission is working, as well as Samba and SSH
    - when trying to connect to the WebGui: 502 Bad Gateway |Nginx

    The only "unusual" thing about this setup is that I run Transmission this way. No idea if it could have interfere in the upgrading process.

    I don't mind starting back on a fresh version of OMV 4.x if that's the best way to go, but I want to keep my current configuration based on a MegerFS pool & Snapraid.


  • I tried to figure what was happening but it was a nightmare (as far as my knowledge goes).

    I had a spare SSD around so I used it to test a fresh install of OMV 4.x on it.

    Once done, I rebooted with data and parity drives connected, but couldn't do a thing as errors popped up.

    I disconnected the drives, booted again and install Snapraid and Mergerfs plugins. Reconnected the drives, rebooted fine this time, then I recreated the pool and Snapraid configuration (took me <1min). My data & parity disks were recognised as on my previous OMV 3.x version.

    This operation didn't do a thing to my data in the process.

    And Voilà, all is up and running!

    In the end, I would be curious to know what caused the issue in the first place...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!