Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin ...

  • Hello,

    after the upgrade from omv 3 to 4, I am trying so add some shared folders or remove some, where the hdd does not exist anymore.
    For both I get:

    For 'journalctl -xe' I get:

    Can anybody please help me, how to fix the problem? ;(

    Regards, Tomte

  • Thanks for the answer!
    It was an USB drive, I pulled it off. Not nice, but I did it.
    Is this really the problem? Do I need to find it, attach it, and then I can remove it?

    Yes!! Attach the drive, remove any shared folders associated with that drive, you'll probably get a save configuration message come and apply changes, do that with each share. If you have Samba shares do them first, then remove/unmount the drive again save configuration, the error regarding the shared folder/s and the 'mount has failed' should resolve themselves.

  • I have a similar error in OMV5 when I try to mount a drive

    what could it be?

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run fstab 2>&1' with exit code '1': /usr/lib/python3/dist-packages/salt/utils/ DeprecationWarning: Using or importing the ABCs from 'collections' instead of from '' is deprecated, and in 3.8 it will stop working if not isinstance(exes, collections.Iterable): /usr/lib/python3/dist-packages/salt/utils/decorators/ DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly *salt.utils.args.get_function_argspec(original_function) nanopim4: ---------- ID: create_filesystem_mountpoint_110da769-901d-4e0d-b38b-0abd88f7c8c2 Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_110da769-901d-4e0d-b38b-0abd88f7c8c2 for file /etc/fstab was charged by text Started: 21:52:26.337983 Duration: 1.697 ms Changes: ---------- ID: mount_filesystem_mountpoint_110da769-901d-4e0d-b38b-0abd88f7c8c2 Function: mount.mounted Name: /srv/dev-disk-by-label-Untitled Result: False Comment: mount: /srv/dev-disk-by-label-Untitled: unknown filesystem type 'exfat'. Started: 21:52:26.357959 Duration: 1075.033 ms Changes: ---------- ID: append_fstab_entries Function: file.blockreplace Name: /etc/fstab Result: True Comment: Changes were made Started: 21:52:27.434826 Duration: 11.381 ms Changes: ---------- diff: --- +++ @@ -1,2 +1,5 @@ UUID=3795425a-ea8c-4a26-8861-09da07c2eddc / ext4 defaults,noatime,nodiratime,commit=600,errors=remount-ro 0 1 tmpfs /tmp tmpfs defaults,nosuid 0 0 +# >>> [openmediavault] +/dev/disk/by-label/Untitled /srv/dev-disk-by-label-Untitled exfat defaults,nofail 0 2 +# <<< [openmediavault] Summary for nanopim4 ------------ Succeeded: 2 (changed=1) Failed: 1 ------------ Total states run: 3 Total run time: 1.088 s    

  • I too have the same error, but my HDD is still attached?!?!?
    I simply tried to unmount and unshare a test share folder and this happened.
    It reoccurs *every* time I try to add a new share....

    Same issue.
    I have OMV running on ubuntu, usb drive ext4 attached with shared folder.
    I changed "privileges" for this shared-folder adding write/read permission for a user (to allow ftp access to it) and now when I apply changes I have this issue.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!